diff mbox series

[bug#46752] gnu: emacs-pyim: Update to 3.2.

Message ID ea00f98495789dfb0fc3e21c538cd7d7c533214e.1614173383.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#46752] gnu: emacs-pyim: Update to 3.2. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen Feb. 24, 2021, 1:31 p.m. UTC
emacs-pyim was recently added to GNU ELPA.

* gnu/packages/emacs-xyz.scm (emacs-pyim): Update to 3.2.
[source]: Fetch tarball from ELPA.

Signed-off-by: Xinglu Chen <public@yoctocell.xyz>
---
 gnu/packages/emacs-xyz.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)


base-commit: 8f250012539675c9d43bd2e52f6eb058dc583850

Comments

Xinglu Chen Feb. 24, 2021, 1:38 p.m. UTC | #1
On Wed, Feb 24 2021, Xinglu Chen wrote:

> * gnu/packages/emacs-xyz.scm (emacs-pyim): Update to 3.2.
> [source]: Fetch tarball from ELPA.

Sorry, this was already pushed in
ac2ff1ba6978a6758268d526f087250c04efcd57.
Nicolas Goaziou Feb. 24, 2021, 3:58 p.m. UTC | #2
Hello,

Xinglu Chen <public@yoctocell.xyz> writes:

> On Wed, Feb 24 2021, Xinglu Chen wrote:
>
>> * gnu/packages/emacs-xyz.scm (emacs-pyim): Update to 3.2.
>> [source]: Fetch tarball from ELPA.
>
> Sorry, this was already pushed in
> ac2ff1ba6978a6758268d526f087250c04efcd57.

Indeed! Closing this report.

Regards,
Arun Isaac May 8, 2021, 5:16 p.m. UTC | #3
Hi,

I'm closing this bug report (46752) since it appears to be a duplicate
of bug 46751.

Thanks!
Arun
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9ec9e1dc79..b0ea14ba8e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -93,6 +93,7 @@ 
 ;;; Copyright © 2021 Alexandr Vityazev <avityazew@gmail.com>
 ;;; Copyright © 2021 Yurii Kholodkov <urist.mckorobochka@gmail.com>
 ;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -12299,16 +12300,15 @@  containing words from the Rime project.")
 (define-public emacs-pyim
   (package
     (name "emacs-pyim")
-    (version "2.0")
+    (version "3.2")
     (source
      (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/tumashu/pyim")
-             (commit (string-append "v" version))))
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/"
+                           "pyim-" version ".tar"))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "06ahzyi2h353xj17mzsm9fxmkc6cyzd1mjzmvqfw8cyv538nijc0"))))
+        (base32 "1rr9mq334dqf7mx1ii7910zkigw7chl63iws4sw0qsn014kjlb0a"))))
     (build-system emacs-build-system)
     (propagated-inputs
      `(("emacs-async" ,emacs-async)