diff mbox series

[bug#49345] Add CL-Hunchenissr-Routes and Its Dependencies

Message ID eU6JlTSXeG5kcDBmO2CyDp_KDjY_yA2YRjmKDO7Smk7OvlgfZ32YP33FkNar9ylIx5ZWZP71h_UFh3ZILPojN7jDIixp2NKQAS3CWnycrQM=@protonmail.com
State Accepted
Headers show
Series [bug#49345] Add CL-Hunchenissr-Routes and Its Dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Charles July 3, 2021, 3:44 p.m. UTC
Sorry about that, the the patch (and some how commit 😢) for cl-portal got deleted and I didn't notice when sending email.
‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Saturday, July 3rd, 2021 at 7:39 AM, Guillaume Le Vaillant <glv@posteo.net> wrote:

> Charles via Guix-patches via guix-patches@gnu.org skribis:
>
> > Just let me know if this is to big of a change for an email or if anything else is wrong with it.
>
> Having many patches attached to an email is not a problem. However all
>
> your patches have the same "0001" prefix, it would be better if the
>
> prefixes had the right number indicating in which order the patches must
>
> be applied (although in this case it was not hard to find out).
>
> I pushed cl-unification, cl-trivial-with-current-source-form, cl-tailrec
>
> and cl-issr-core with a few modifications as
>
> e2e17903fbb726467d74d8da367f51fa0206a12b and following.
>
> However cl-hunchenissr requires the cl-portal package which is
>
> apparently missing from your patches.
>
> Could you send updated patches for cl-portal, cl-hunchenissr and
>
> cl-hunchenissr-routes?

Comments

Guillaume Le Vaillant July 5, 2021, 8:14 a.m. UTC | #1
Paches pushed as 16418a974f98acb22fbef1a8789b794bb8f6fabe and following
with a few modifications (missing 'file-name', typos, etc).
Thanks.
diff mbox series

Patch

From 1b95b1ff395533aa4e74b2728b8d2a016000b28f Mon Sep 17 00:00:00 2001
From: Charles <charles.b.jackson@protonmail.com>
Date: Sat, 26 Jun 2021 10:12:34 -0500
Subject: [PATCH] gnu: Add cl-hunchenissr-routes.

* gnu/packages/lisp-xyz.scm (sbcl-hunchenissr-routes): Add new variable.
* gnu/packages/lisp-xyz.scm (ecl-hunchenissr-routes): Add new variable.
* gnu/packages/lisp-xyz.scm (cl-hunchenissr-routes): Add new variable.
---
 gnu/packages/lisp-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index bb264ac621..c602ee5f2d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18352,3 +18352,37 @@  Javascript.")
 (define-public cl-hunchenissr
   (sbcl-package->cl-source-package sbcl-hunchenissr))
 
+(define-public sbcl-hunchenissr-routes
+  (let ((commit "2e831975dc2a6c030f1b518747cf429be8484b31")
+        (revision "1"))
+    (package
+      (name "sbcl-hunchenissr-routes")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/interactive-ssr/hunchenissr-routes")
+               (commit commit)))
+         (file-name (git-file-name "hunchenissr-routes" version))
+         (sha256
+          (base32 "1xyqacihxwk4vnffqlg93czmalscglp6sh3bwy3qwb7hdxv6yxz6"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("sbcl-alexandria" ,sbcl-alexandria)
+         ("sbcl-cl-ppcre" ,sbcl-cl-ppcre)
+         ("sbcl-cl-unification" ,sbcl-cl-unification)
+         ("sbcl-hunchenissr" ,sbcl-hunchenissr)))
+      (home-page "https://github.com/interactive-ssr/hunchenissr-routes")
+      (synopsis "Enable path variables when using Hunchenissr for Common Lisp.")
+      (description "Enable path variables in networking routes when using
+Hunchenissr for Common Lisp. If a part of the path (between two slashes) starts
+with a question mark (?), that symbol (without question mark) will bound to
+whatever value was in the same place in the URL (as a string).")
+      (license license:llgpl))))
+
+(define-public ecl-hunchenissr-routes
+  (sbcl-package->ecl-package sbcl-hunchenissr-routes))
+
+(define-public cl-hunchenissr
+  (sbcl-package->cl-source-package sbcl-hunchenissr-routes))
-- 
2.32.0