[bug#78393] gnu: Add go-github-com-jwt

Message ID eSuU_pnW-MeYWCp510Bu9hAcKBqn8xaYimOUKLAAytzA60_rhA4G4WBgqsUdXQTpF6Cbvvd9MdEEAK8GZbHnhTC3zOB7S7Ho2O5gLF1wk2M=@proton.me
State New
Headers
Series [bug#78393] gnu: Add go-github-com-jwt |

Commit Message

arthurhdrodrigues--- via Guix-patches via May 12, 2025, 3:12 p.m. UTC
  Hi guix, first time contributor here :)

This patch adds go-github-com-jwt, a Golang library to handle JSON Web Tokens.

I plan to package [act](https://github.com/nektos/act) and thought it would be
better to submit one of its dependencies and gather some feedback before submitting
a patch series for the rest of them and for the software itself.

Thank you for any feedback.


---
 gnu/packages/golang-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: 300d29e69988caf23684f08effa51f621c7ec083
  

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 21d2b05abc..37827ab775 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -8889,6 +8889,32 @@  (define-public go-github-com-juju-ansiterm
 for color and styles.")
     (license license:lgpl3)))
 
+(define-public go-github-com-jwt
+  (package
+    (name "go-github-com-jwt")
+    (version "5.2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/golang-jwt/jwt")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zlx62zdvii8080m22bs4mwi2mb8f475bkaa86fiwndi1c722hqb"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/golang-jwt/jwt"))
+    (home-page "https://golang-jwt.github.io/jwt")
+    (synopsis "Go implementation of JSON Web Tokens")
+    (description
+     "This library provides a Go implementation of JSON Web Tokens (JWT).
+     JWT is an open standard that defines a compact and self-contained
+     way for securely transmitting information between parties as a
+     JSON object.")
+    (license license:expat)))
+
 (define-public go-github-com-k0kubun-go-ansi
   (package
     (name "go-github-com-k0kubun-go-ansi")