diff mbox series

[bug#48553] gnu: Add numdiff.

Message ID eCTMwGegwelEl5doYTIOYRAxhX2bYBa2XPtogeYoXgordf_FgWE-7qxHTsjxGij6T8U8apYZCsgm5Rh1KjV_WVcezHXQw37EzXuXOe0NG28=@apatience.com
State Accepted
Headers show
Series [bug#48553] gnu: Add numdiff. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience May 21, 2021, 2:50 a.m. UTC
* gnu/packages/maths.scm (numdiff): New variable.
---
 gnu/packages/maths.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

--
2.31.1

Comments

Roel Janssen May 21, 2021, 10:37 a.m. UTC | #1
Hi Paul,

I pushed this patch with a minor modifications I outline below.

On Fri, 2021-05-21 at 02:50 +0000, Paul A. Patience wrote:
> * gnu/packages/maths.scm (numdiff): New variable.
> ---
>  gnu/packages/maths.scm | 30 ++++++++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)
> 
> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
> index 6b3f5cf41c..98be1bc211 100644
> --- a/gnu/packages/maths.scm
> +++ b/gnu/packages/maths.scm
> @@ -45,6 +45,7 @@
>  ;;; Copyright © 2021 Gerd Heber <gerd.heber@gmail.com>
>  ;;; Copyright © 2021 Franck Pérignon < 
> franck.perignon@univ-grenoble-alpes.fr>
>  ;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
> +;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -6229,3 +6230,32 @@ and conversions, physical constants, symbolic
> calculations (including
>  integrals and equations), arbitrary precision, uncertainty
> propagation,
>  interval arithmetic, plotting.")
>      (license license:gpl2+)))
> +
> +(define-public numdiff
> +  (package
> +    (name "numdiff")
> +    (version "5.9.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append " 
> http://savannah.nongnu.org/download/numdiff/numdiff-"
> +                           version ".tar.gz"))

I changed the URI to "mirror://savannah/numdiff/numdiff-...".

> +       (sha256
> +        (base32
> +         "1vzmjh8mhwwysn4x4m2vif7q2k8i19x8azq7pzmkwwj4g48lla47"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     '(#:tests? #f
> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-before 'compress-documentation 'delete-precompressed-
> info-file
> +           (lambda _
> +             (delete-file (string-append (assoc-ref %outputs "out")
> +                                        
> "/share/info/numdiff.info.gz"))
> +             #t)))))
> +    (home-page "https://nongnu.org/numdiff/")
> +    (synopsis "Compare files with numeric fields")
> +    (description
> +     "Numdiff compares files line by line and field by field,
> ignoring small
> +numeric differences and differences in numeric formats.")
> +    (license license:gpl3+)))
> --
> 2.31.1
> 

Thanks you!

Kind regards,
Roel Janssen
Roel Janssen May 21, 2021, 10:39 a.m. UTC | #2
On Fri, 2021-05-21 at 02:50 +0000, Paul A. Patience wrote:
> * gnu/packages/maths.scm (numdiff): New variable.
> ---
>  gnu/packages/maths.scm | 30 ++++++++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)
> 
> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
> index 6b3f5cf41c..98be1bc211 100644
> --- a/gnu/packages/maths.scm
> +++ b/gnu/packages/maths.scm
> @@ -45,6 +45,7 @@
>  ;;; Copyright © 2021 Gerd Heber <gerd.heber@gmail.com>
>  ;;; Copyright © 2021 Franck Pérignon
> <franck.perignon@univ-grenoble-alpes.fr>
>  ;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
> +;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -6229,3 +6230,32 @@ and conversions, physical constants, symbolic
> calculations (including
>  integrals and equations), arbitrary precision, uncertainty
> propagation,
>  interval arithmetic, plotting.")
>      (license license:gpl2+)))
> +
> +(define-public numdiff
> +  (package
> +    (name "numdiff")
> +    (version "5.9.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> "http://savannah.nongnu.org/download/numdiff/numdiff-"
> +                           version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "1vzmjh8mhwwysn4x4m2vif7q2k8i19x8azq7pzmkwwj4g48lla47"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     '(#:tests? #f
> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-before 'compress-documentation 'delete-precompressed-
> info-file
> +           (lambda _
> +             (delete-file (string-append (assoc-ref %outputs "out")
> +                                        
> "/share/info/numdiff.info.gz"))
> +             #t)))))
> +    (home-page "https://nongnu.org/numdiff/")
> +    (synopsis "Compare files with numeric fields")
> +    (description
> +     "Numdiff compares files line by line and field by field,
> ignoring small
> +numeric differences and differences in numeric formats.")
> +    (license license:gpl3+)))
> --
> 2.31.1
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6b3f5cf41c..98be1bc211 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -45,6 +45,7 @@ 
 ;;; Copyright © 2021 Gerd Heber <gerd.heber@gmail.com>
 ;;; Copyright © 2021 Franck Pérignon <franck.perignon@univ-grenoble-alpes.fr>
 ;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6229,3 +6230,32 @@  and conversions, physical constants, symbolic calculations (including
 integrals and equations), arbitrary precision, uncertainty propagation,
 interval arithmetic, plotting.")
     (license license:gpl2+)))
+
+(define-public numdiff
+  (package
+    (name "numdiff")
+    (version "5.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://savannah.nongnu.org/download/numdiff/numdiff-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "1vzmjh8mhwwysn4x4m2vif7q2k8i19x8azq7pzmkwwj4g48lla47"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'compress-documentation 'delete-precompressed-info-file
+           (lambda _
+             (delete-file (string-append (assoc-ref %outputs "out")
+                                         "/share/info/numdiff.info.gz"))
+             #t)))))
+    (home-page "https://nongnu.org/numdiff/")
+    (synopsis "Compare files with numeric fields")
+    (description
+     "Numdiff compares files line by line and field by field, ignoring small
+numeric differences and differences in numeric formats.")
+    (license license:gpl3+)))