diff mbox series

[bug#69264] gnu: qtwayland: Add search path for QT_PLUGIN_PATH.

Message ID e9eb649d14bd7619c7f548b454a23232d064378e.1708097194.git.hako@ultrarare.space
State New
Headers show
Series [bug#69264] gnu: qtwayland: Add search path for QT_PLUGIN_PATH. | expand

Commit Message

Hilton Chain Feb. 19, 2024, 7:40 a.m. UTC
* gnu/packages/qt.scm (qtwayland)[native-search-paths]: Add QT_PLUGIN_PATH.

Change-Id: I264114e994099e1b46ccddcee956ced929bd6a7e
---
 gnu/packages/qt.scm | 4 ++++
 1 file changed, 4 insertions(+)


base-commit: e3586aa61d58fd8992abb594edc2168d5bf5a6da

Comments

Hilton Chain March 1, 2024, 6:20 a.m. UTC | #1
Applied as 24eabd1eff34673d4a93edf16f92c444cdc1ac3f, closing.
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index c501219437..761d12e31f 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1906,6 +1906,10 @@  (define-public qtwayland
            qtbase
            vulkan-headers
            wayland))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "QT_PLUGIN_PATH")
+            (files '("lib/qt6/plugins")))))
     (synopsis "Qt Wayland module")
     (description "The Qt Wayland module provides the QtWayland client and
 compositor libraries.")