[bug#77372] gnu: Add python-obspy.

Message ID e9bf69aa43eefee96c478553e7d1059ae2a06e3a.1743289704.git.monego@posteo.net
State New
Headers
Series [bug#77372] gnu: Add python-obspy. |

Commit Message

Vinicius Monego March 29, 2025, 11:14 p.m. UTC
  * gnu/packages/geo.scm (python-obspy): New variable.

Change-Id: I116d39d02f8b42c8b4ea3aaef75c388744d7f58d
---
 gnu/packages/geo.scm | 43 ++++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 42 insertions(+), 1 deletion(-)


base-commit: a3674c059abf16256f549c4d558a0140b9cd8945
  

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8682d29e0e..022bb45d1e 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -15,7 +15,7 @@ 
 ;;; Copyright © 2020 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2020–2024 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021, 2023-2025 Sharlatan Hellseher <sharlatanus@gmail.com>
-;;; Copyright © 2021, 2023, 2024 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021, 2023, 2024, 2025 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2021, 2022 Nikolay Korotkiy <sikmir@disroot.org>
 ;;; Copyright © 2022 Patrick Noll <patrick@patricknoll.com>
@@ -960,6 +960,47 @@  (define-public proj.4
                    ;; cmake/*
                    license:boost1.0))))
 
+(define-public python-obspy
+  (package
+    (name "python-obspy")
+    (version "1.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "obspy" version))
+       (sha256
+        (base32 "0izpsfcgjzdj0ja0lip86agp1gfxpw3c00w77603vr1xw067pwww"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; Rebuild shared libraries to run tests
+          (add-before 'check 'rebuild-ext
+            (lambda _
+              (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+    (propagated-inputs (list python-decorator
+                             python-lxml
+                             python-matplotlib
+                             python-numpy
+                             python-requests
+                             python-scipy
+                             python-setuptools
+                             python-sqlalchemy))
+    (native-inputs (list python-packaging python-pyproj python-pytest
+                         python-setuptools python-wheel))
+    (home-page "https://www.obspy.org")
+    (synopsis "Python framework for seismological observatories")
+    (description
+     "@code{ObsPy} is a project dedicated to provide a Python framework for
+processing seismological data.  It provides parsers for common file formats,
+clients to access data centers and seismological signal processing routines
+which allow the manipulation of seismological time series.
+
+The goal of the ObsPy project is to facilitate rapid application development
+for seismology.")
+    (license license:lgpl3)))
+
 (define-public python-pyogrio
   (package
     (name "python-pyogrio")