diff mbox series

[bug#38347] gnome-contacts v2

Message ID e998c9e0b234b5e8d78498963fe94fa48ce0e556.camel@disroot.org
State Accepted
Headers show
Series [bug#38347] gnome-contacts v2 | expand

Commit Message

Raghav Gururajan Nov. 23, 2019, 8:56 p.m. UTC
Hello Guix!

Please find the attached file containing revised patch for gnome-
contacts.

Thank you!

Regards,
RG.

Comments

Ludovic Courtès Dec. 8, 2019, 10:16 p.m. UTC | #1
Hi,

Raghav Gururajan <raghavgururajan@disroot.org> skribis:

> From 28cb5a45af5ff85365c5bcb4745f4e87d9d3d0bd Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Sat, 23 Nov 2019 15:52:17 -0500
> Subject: [PATCH 4/4] gnu: Add gnome-contacts.
>
> * gnu/packages/gnome.scm (gnome-contacts): New Variable.

I merged the two patches, addressed the ‘guix lint’ warnings, and pushed
as 4e868d22e6fedb439910c50bb5c61ab712a479be with a followup commit.

I tried it under GNOME in a VM and it’s not entirely clear that it’s
working as expected: it seems to be expecting to import the address book
from an online service but doesn’t know of any?

Thank you,
Ludo’.
Raghav Gururajan Dec. 9, 2019, 12:44 p.m. UTC | #2
Hello Ludo!

> I merged the two patches, addressed the ‘guix lint’ warnings, and
> pushed
> as 4e868d22e6fedb439910c50bb5c61ab712a479be with a followup commit.
> 
> I tried it under GNOME in a VM and it’s not entirely clear that it’s
> working as expected: it seems to be expecting to import the address
> book
> from an online service but doesn’t know of any?

Thank you very much.

I believe it can be tried with 'evolution-data-server' as propagated
input.

Let me try and get back to you.

AFAIK, it can create local contacts or sync contacts from online
accounts (WebDAV).

Regards,
RG.
Raghav Gururajan Dec. 21, 2019, 4:28 a.m. UTC | #3
Hello Ludo!

> > I merged the two patches, addressed the ‘guix lint’ warnings, and
> > pushed
> > as 4e868d22e6fedb439910c50bb5c61ab712a479be with a followup commit.
> > 
> > I tried it under GNOME in a VM and it’s not entirely clear that
> > it’s
> > working as expected: it seems to be expecting to import the address
> > book
> > from an online service but doesn’t know of any?
> 
> Thank you very much.
> 
> I believe it can be tried with 'evolution-data-server' as propagated
> input.
> 
> Let me try and get back to you.
> 
> AFAIK, it can create local contacts or sync contacts from online
> accounts (WebDAV).

The application is working fine on my end. No need of 'eds' as
propagated input.

Regards,
RG.
diff mbox series

Patch

From 28cb5a45af5ff85365c5bcb4745f4e87d9d3d0bd Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sat, 23 Nov 2019 15:52:17 -0500
Subject: [PATCH 4/4] gnu: Add gnome-contacts.

* gnu/packages/gnome.scm (gnome-contacts): New Variable.
---
 gnu/packages/gnome.scm | 95 +++++++++++++++++++++---------------------
 1 file changed, 48 insertions(+), 47 deletions(-)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index febc874b31..d72f81dac6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -499,53 +499,54 @@  commonly used macros.")
 
 (define-public gnome-contacts
   (package
-    (name "gnome-contacts")
-    (version "3.30.2")
-    (source (origin
-	      (method url-fetch)
-	      (uri (string-append "mirror://gnome/sources/" name "/"
-				  (version-major+minor version) "/"
-				  name "-" version ".tar.xz"))
-	      (sha256
-	       (base32 
-		"1b0pkdwz9yqcv82zzdf76rs2w3wa5zli8pka09wnahikx1ykk43h"))))
-    (build-system meson-build-system)
-    (arguments
-      `(#:phases
-        (modify-phases %standard-phases
-          (add-after 'unpack 'generate-vapis
-            (lambda* (#:key inputs #:allow-other-keys)
-              (invoke "vapigen" "--directory=vapi" "--pkg=gio-2.0"
-                      "--library=goa-1.0"
-                      (string-append (assoc-ref inputs "gnome-online-accounts:lib")
-                                     "/share/gir-1.0/Goa-1.0.gir"))
-              #t)))))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("vala" ,vala)
-       ("glib:bin" ,glib "bin")
-       ("gobject-introspection" ,gobject-introspection)
-       ("libgee" ,libgee)
-       ("evolution-data-server" ,evolution-data-server)
-       ("gnome-desktop" ,gnome-desktop)
-       ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
-       ("cheese" ,cheese)
-       ("gst-plugins-base" ,gst-plugins-base)
-       ("telepathy-glib" ,telepathy-glib)
-       ("gettext" ,gettext-minimal)
-       ("libxslt" ,libxslt)
-       ("docbook-xml" ,docbook-xml)
-       ("dockbook-xsl" ,docbook-xsl)
-       ("gtk+" ,gtk+)
-       ("gtk+:bin" ,gtk+ "bin")))
-    (propagated-inputs
-     `(("folks", folks)
-       ("telepathy-mission-control" ,telepathy-mission-control)))
-    (synopsis "Contacts is GNOME's integrated address book.")
-    (description "It is written in Vala and uses 
-		 libfolks (also written in Vala) and Evolution Data Server.")
-    (home-page "https://wiki.gnome.org/Apps/Contacts")
-    (license gpl2))
+   (name "gnome-contacts")
+   (version "3.30.2")
+   (source (origin
+	    (method url-fetch)
+	    (uri (string-append "mirror://gnome/sources/gnome-contacts/"
+				(version-major+minor version) "/"
+				name "-" version ".tar.xz"))
+	    (sha256
+	     (base32 
+	      "1b0pkdwz9yqcv82zzdf76rs2w3wa5zli8pka09wnahikx1ykk43h"))))
+   (build-system meson-build-system)
+   (arguments
+    `(#:phases
+      (modify-phases %standard-phases
+		     (add-after 'unpack 'generate-vapis		;; To generate goa's missing .vapi file
+				(lambda* (#:key inputs #:allow-other-keys)
+				  (invoke "vapigen" "--directory=vapi" "--pkg=gio-2.0"
+					  "--library=goa-1.0"
+					  (string-append (assoc-ref inputs "gnome-online-accounts:lib")
+							 "/share/gir-1.0/Goa-1.0.gir"))
+				  #t)))))
+   (native-inputs
+    `(("glib:bin" ,glib "bin")
+      ("gtk+:bin" ,gtk+ "bin")))
+   (inputs
+    `(("cheese" ,cheese)
+      ("docbook-xml" ,docbook-xml)
+      ("dockbook-xsl" ,docbook-xsl)
+      ("evolution-data-server" ,evolution-data-server)
+      ("gettext" ,gettext-minimal)
+      ("gnome-desktop" ,gnome-desktop)
+      ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
+      ("gobject-introspection" ,gobject-introspection)
+      ("gst-plugins-base" ,gst-plugins-base)
+      ("gtk+" ,gtk+)
+      ("libgee" ,libgee)
+      ("libxslt" ,libxslt)
+      ("pkg-config" ,pkg-config)
+      ("telepathy-glib" ,telepathy-glib)
+      ("vala" ,vala)))
+   (propagated-inputs
+    `(("folks", folks)
+      ("telepathy-mission-control" ,telepathy-mission-control)))
+   (synopsis "GNOME's integrated address book.")
+   (description "Contacts organizes your contacts information from all your online 
+		 and offline sources, providing a centralized place for managing your contacts.")
+   (home-page "https://wiki.gnome.org/Apps/Contacts")
+   (license license:gpl2+))
 
 (define-public gnome-desktop
   (package
-- 
2.24.0