diff mbox series

[bug#65743,2/2] gnu: python-qtsass: Update to 0.4.0, fix build.

Message ID e96b1b6dfe811bf406d2e4ed6ea7b55efd77362a.1693849464.git.sharlatanus@gmail.com
State New
Headers show
Series gnu: python-qtsass: Update to 0.4.0, fix build. | expand

Commit Message

Sharlatan Hellseher Sept. 4, 2023, 7:19 p.m. UTC
* gnu/packages/python-xyz.scm (python-qtsass): Update to 0.4.0, fix
build.
[native-inputs]: Add python-flaky.
---
 gnu/packages/python-xyz.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5410f294d5..16bb186a29 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30006,7 +30006,7 @@  (define-public python-helper
 (define-public python-qtsass
   (package
     (name "python-qtsass")
-    (version "0.3.0")
+    (version "0.4.0")
     (source
      (origin
        ;; There are no tests in the PyPI tarball.
@@ -30016,7 +30016,7 @@  (define-public python-qtsass
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "09s04aa14d8jqbh71clrb5y7vcmkxlp94mwmvzrkxahry3bk03cb"))))
+        (base32 "1skdihfby2f41zxgwa5zv44vdxjrw301rh88rjmzj4xbdlix6cig"))))
     (build-system python-build-system)
     (arguments
      `(#:test-target "pytest"
@@ -30028,7 +30028,7 @@  (define-public python-qtsass
              (for-each make-file-writable (find-files "."))
              #t)))))
     (native-inputs
-     (list python-pytest python-pytest-cov python-pytest-runner))
+     (list python-flaky python-pytest python-pytest-cov python-pytest-runner))
     (propagated-inputs
      (list python-libsass))
     (home-page "https://github.com/spyder-ide/qtsass")