diff mbox series

[bug#73011] gnu: go-github-com-elliotchance-orderedmap: Fix tests.

Message ID e966d8a3c08c23e9f25e355b8a23c6eccc2c32a9.1725398734.git.code@greghogan.com
State New
Headers show
Series [bug#73011] gnu: go-github-com-elliotchance-orderedmap: Fix tests. | expand

Commit Message

Greg Hogan Sept. 3, 2024, 9:27 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-elliotchance-orderedmap)
[arguments]<#:phases>: Replace 'check and only run short tests so as to
exclude flaky performance tests.

Change-Id: If9fbc5510643f9d5e3ccff09f71e00a9cdfbe92f
---
 gnu/packages/golang-xyz.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)


base-commit: 19e0b937857563e77841a4fc5433589fa98c810d

Comments

Sharlatan Hellseher Sept. 4, 2024, 9:15 a.m. UTC | #1
Hi Greg,

Thanks for the patch.

I've applied minor modification to the patch to make sure "v2" inherits
replaced check phase as well.

Pushed as 5b841a42fbf3ffd929ba76e37753ba1cb4797125 to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 796341a66bc..6c17d0a74b9 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2154,7 +2154,15 @@  (define-public go-github-com-elliotchance-orderedmap
         (base32 "1hhyk96l6mfijkay9ga6jqpczpn34fbqkjrqj3v9pf5p1hzd0xdx"))))
     (build-system go-build-system)
     (arguments
-     (list #:import-path "github.com/elliotchance/orderedmap"))
+     (list #:import-path "github.com/elliotchance/orderedmap"
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? import-path #:allow-other-keys)
+                   (when tests?
+                     ;; The full test suite runs flaky performance tests,
+                     ;; so only run the short tests.
+                     (invoke "go" "test" "-test.short" import-path)))))))
     (native-inputs
      (list go-github-com-stretchr-testify))
     (home-page "https://github.com/elliotchance/orderedmap")