[bug#75991,2/3] gnu: tinygltf: Install a library.

Message ID e95354487a07043c3b898f62f5be624b2572fcc8.1738421170.git.maxim.cournoyer@gmail.com
State New
Headers
Series Udate Speed Dreams game to 2.4.0-rc1 |

Commit Message

Maxim Cournoyer Feb. 1, 2025, 3:50 p.m. UTC
  Previously, only a static library would be produced and then deleted in a
phase.

* gnu/packages/graphics.scm (tinygltf) [arguments]: Add #:configure-flags.
<phases>: Remove delete-static-lib.

Change-Id: I019a87a4fbf68fc19270a41d58af3a2184b77215
---
 gnu/packages/graphics.scm | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)
  

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 595e188de1..1492740f9c 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2611,6 +2611,7 @@  (define-public tinygltf
     (build-system cmake-build-system)
     (arguments
      (list
+      #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'use-our-packages
@@ -2623,10 +2624,6 @@  (define-public tinygltf
                        "stb_image_write.h")
               (symlink (search-input-file inputs "include/catch.hpp")
                        "catch.hpp")))
-          (add-after 'install 'delete-static-lib
-            (lambda _
-              (delete-file (string-append #$output
-                                          "/lib/libtinygltf.a"))))
           (replace 'check
             (lambda* (#:key tests? #:allow-other-keys)
               (if tests?