diff mbox series

[bug#64767,2/5] gnu: libcamera: Split off gst and tools outputs.

Message ID e948ae55f873847d98debffbd76cf9684c5f8594.1689941427.git.iyzsong@member.fsf.org
State New
Headers show
Series Update libcamera and pipewire | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via July 21, 2023, 12:14 p.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/networking.scm (libcamera)[outputs]: Add gst and tools.
[arguments]: Pass "-Dbindir" to configure-flags.  Adjust 'move-doc phase
to 'move-doc-and-gst.
---
 gnu/packages/networking.scm | 14 ++++++++++----
 1 file changed, 10 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 52178785d3..84091274f0 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -363,25 +363,31 @@  (define-public libcamera
        (sha256
         (base32 "06dj3dpfbayj61015n5kffin2g3hyys11ra0px2g4hmrznvdkhc9"))))
     (build-system meson-build-system)
-    (outputs '("out" "doc"))
+    (outputs '("out" "doc" "gst" "tools"))
     (arguments
      `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
        #:configure-flags
        (list
+        (string-append "-Dbindir=" (assoc-ref %outputs "tools") "/bin")
         "-Dtest=true"
         "-Dv4l2=true"
         ;; XXX: Requires bundled pybind11.
         "-Dpycamera=disabled")
        #:phases
        (modify-phases %standard-phases
-         (add-after 'install 'move-doc
+         (add-after 'install 'move-doc-and-gst
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
-                    (doc (assoc-ref outputs "doc")))
+                    (doc (assoc-ref outputs "doc"))
+                    (gst (assoc-ref outputs "gst")))
                (mkdir-p (string-append doc "/share"))
                (rename-file
                 (string-append out "/share/doc")
-                (string-append doc "/share/doc"))))))))
+                (string-append doc "/share/doc"))
+               (mkdir-p (string-append gst "/lib"))
+               (rename-file
+                (string-append out "/lib/gstreamer-1.0")
+                (string-append gst "/lib/gstreamer-1.0"))))))))
     (native-inputs
      (list googletest
            graphviz                     ;for 'dot'