[bug#74768,1/2] gnu: gnunet: Update to 0.23.0.
Commit Message
* gnu/packages/gnunet.scm (gnunet): Update to 0.23.0.
[phases]: Adjust disable-problematic-tests phase.
Change-Id: Ibf900d929bcd257932c6997eacbfaeeda1aa7f26
---
gnu/packages/gnunet.scm | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)
@@ -192,7 +192,7 @@ (define-public libmicrohttpd
(define-public gnunet
(package
(name "gnunet")
- (version "0.21.2")
+ (version "0.23.0")
(source
(origin
(method url-fetch)
@@ -200,7 +200,7 @@ (define-public gnunet
".tar.gz"))
(sha256
(base32
- "18czv9yxxmaf7y061ngzwcc9rxwrwdy372wb52ns52wviqk528wc"))))
+ "0ypnsn81fp3iqi8rgsbcvfnz9iwmaxd1h71mphak8ska2kabdim4"))))
(build-system gnu-build-system)
(inputs
(list bluez
@@ -240,6 +240,11 @@ (define-public gnunet
#~(modify-phases %standard-phases
(add-after 'unpack 'disable-problematic-tests
(lambda _
+ ;; The file 'test_arm_probnat.sh' doesn't seem to exist,
+ ;; or have a creation method specified anywhere in the source.
+ (substitute* "src/service/arm/Makefile.in"
+ (("check_SCRIPTS = \\\\")
+ "DISABLED_check_SCRIPTS = \\"))
;; The 'test_communicator_bidirect-tcp' fails
;; non-deterministically (see:
;; https://bugs.gnunet.org/view.php?id=8689).