diff mbox series

[bug#68039,rust-team] gnu: librsvg: Improve cross compiling.

Message ID e935a3a3670911addd41af1732bf68e6f5cd03a9.1703352828.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#68039,rust-team] gnu: librsvg: Improve cross compiling. | expand

Commit Message

Zheng Junjie Dec. 26, 2023, 10:38 a.m. UTC
* gnu/packages/gnome.scm (librsvg): Improve cross compiling.
[arguments]<#:phases>: Use platform-rust-target.

Change-Id: I0fd24334286602642b2650fef52c79ea4955c3e8
---
 gnu/packages/gnome.scm | 14 ++++++++------
 1 file changed, 8 insertions(+), 6 deletions(-)


base-commit: 2f9f39f44108884669e7201c8fbf7f7d39e65ff2

Comments

Efraim Flashner Dec. 26, 2023, 11:45 a.m. UTC | #1
Thanks. I've applied it to the rust-team branch.

gnome-team: Feel free to apply it to your branch too if you want. I
didn't make any changes to the patch.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b0417b2df9..339c85489f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -77,6 +77,7 @@ 
 ;;; Copyright © 2023 Juliana Sims <juli@incana.org>
 ;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
 ;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -238,6 +239,7 @@  (define-module (gnu packages gnome)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
+  #:use-module (guix platform)
   #:use-module (guix utils)
   #:use-module (guix gexp)
   #:use-module (ice-9 match)
@@ -3593,12 +3595,12 @@  (define-public librsvg
               ;; In lieu of #:make-flags
               (setenv "CC" #$(cc-for-target))
               (setenv "PKG_CONFIG" #$(pkg-config-for-target))
-              (when #$(%current-target-system)
-                (setenv "RUST_TARGET"
-                        (string-replace
-                          #$(%current-target-system)
-                          "-unknown-linux-gnu"
-                          (string-index #$(%current-target-system) #\-))))
+              #$@(if (%current-target-system)
+                     #~((setenv "RUST_TARGET"
+                                #$(platform-rust-target
+                                   (lookup-platform-by-target
+                                    (%current-target-system)))))
+                     #~())
               ;; Something about the build environment resists building
               ;; successfully with the '--locked' flag.
               (substitute* '("Makefile.am" "Makefile.in")