diff mbox series

[bug#49203,v2,1/2] gnu: Add ocaml-uri-sexp.

Message ID e92510795022371e6f6cf4eba2bbf7f79230900d.1624626240.git.public@yoctocell.xyz
State Accepted
Headers show
Series Add ocaml-cohttp and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen June 25, 2021, 1:07 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-uri-sexp): New variable.
---
 gnu/packages/ocaml.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0eb63b94d4..60a14ce87c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7071,6 +7071,20 @@  Graphics.open_graph is called.  This library used to be distributed with OCaml
 up to OCaml 4.08.")
     (license license:lgpl2.1+)))
 
+(define-public ocaml-uri-sexp
+  (package
+    (inherit ocaml-uri)
+    (arguments
+     '(#:package "uri-sexp"
+       #:test-target "."))
+    (propagated-inputs
+      `(("ocaml-uri" ,ocaml-uri)
+        ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+        ("ocaml-sexplib0" ,ocaml-sexplib0)))
+    (native-inputs `(("ocaml-ounit" ,ocaml-ounit)))
+    (synopsis "RFC3986 URI/URL parsing library")
+    (description "This package adds S-exp support to @code{ocaml-uri}.")))
+
 (define-public js-of-ocaml
   (package
     (name "js-of-ocaml")