[bug#77337,3/3] gnu: gnome-shell: Replace libgnomekbd with tecla.

Message ID e901bb4bba88d333c4f8ef47a01a3db143a921cb.1743157379.git.noelopez@free.fr
State New
Headers
Series gnome: Replace libgnomekbd with tecla. |

Commit Message

NoƩ Lopez March 28, 2025, 1:25 p.m. UTC
  This was changed in GNOME 45.

* gnu/packages/gnome.scm (gnome-shell): Replace libgnomekbd with tecla.

Change-Id: Iad3248319f95fe43c30e83c4ef6a7690f6e123d8
---
 gnu/packages/gnome.scm | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)
  

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 46b008f9c4..46e360067f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9587,14 +9587,13 @@  (define-public gnome-shell
             (add-before 'configure 'record-absolute-file-names
               (lambda* (#:key inputs #:allow-other-keys)
                 (let ((ibus-daemon (search-input-file inputs "bin/ibus-daemon"))
-                      (gkbd-keyboard-display
-                       (search-input-file inputs "bin/gkbd-keyboard-display")))
+                      (tecla (search-input-file inputs "bin/tecla")))
                   (substitute* "js/misc/ibusManager.js"
                     (("'ibus-daemon'")
                      (string-append "'" ibus-daemon "'")))
                   (substitute* "js/ui/status/keyboard.js"
-                    (("'gkbd-keyboard-display'")
-                     (string-append "'" gkbd-keyboard-display "'"))))))
+                    (("'tecla'")
+                     (string-append "'" tecla "'"))))))
             (add-before 'check 'pre-check
               (lambda* (#:key inputs #:allow-other-keys)
                 ;; Tests require a running X server.
@@ -9706,7 +9705,6 @@  (define-public gnome-shell
            ibus
            libcanberra
            libcroco
-           libgnomekbd                  ;for gkbd-keyboard-display
            libgweather4
            libnma
            libsoup
@@ -9718,6 +9716,7 @@  (define-public gnome-shell
            pulseaudio
            python-pygobject
            startup-notification
+           tecla                        ;for keyboard previews
            telepathy-logger
            upower
            ;; XXX: These requirements were added in 3.24, but no mention in NEWS.