[bug#78086] gnu: Add emacs-org-rss-publishing.

Message ID e8d2c44e93a2caedb53d8bf809c390aa1bad9f06.1745747257.git.me@fabionatali.com
State New
Headers
Series [bug#78086] gnu: Add emacs-org-rss-publishing. |

Commit Message

Fabio Natali April 27, 2025, 9:49 a.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-org-rss-publishing): New variable.

Change-Id: I063fa0ba2ba3d87bcde2af8c8e3d04423de4ba2e
---
Hi All. 👋

This is to add 'org-rss-publishing', an RSS generator for Org Mode's built-in
publishing system. See the project page for details:

https://git.sr.ht/~taingram/org-publish-rss

I hope it looks alright, but let me know what you think and if there's anything
that needs to be addressed.

Thanks, cheers, Fabio.


 gnu/packages/emacs-xyz.scm | 28 +++++++++++++++++++++++++++-
 1 file changed, 27 insertions(+), 1 deletion(-)


base-commit: 7e5913f90df916d8d9f5c509354d62324f54f481
  

Comments

Cayetano Santos April 27, 2025, 11:26 a.m. UTC | #1
Hi Fabio,

  A few remarks:

> +      (version (git-version "0.0.0" revision commit))

Version is 0.6, see header in org-publish-rss.el.

> +      (propagated-inputs (list emacs-org))

No need to, emacs includes org.

> +      (license license:gpl3))))

gpl3+ ?

The, try a:

    ./pre-inst-env guix lint emacs-org-rss-publishing

you’ll get:

    sentences in description should be followed by two spaces; possible
    infractions at 155, 268

And don’t forget disable tests, if there are no, as this becomes mandatory:

+    (arguments `(#:tests? #false))      ;no tests

Could you please send a v2 ?

C.
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6d10fb7737..0e0ffef58c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -129,7 +129,7 @@ 
 ;;; Copyright © 2023, 2025 Evgeny Pisemsky <mail@pisemsky.site>
 ;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
 ;;; Copyright © 2022-2023 Simon Josefsson <simon@josefsson.org>
-;;; Copyright © 2023 Fabio Natali <me@fabionatali.com>
+;;; Copyright © 2023, 2025 Fabio Natali <me@fabionatali.com>
 ;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
 ;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
 ;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
@@ -31854,6 +31854,32 @@  (define-public emacs-org-web-tools
 inserts it as an Org entry instead of displaying it in a new buffer.")
     (license license:gpl3+)))
 
+(define-public emacs-org-rss-publishing
+  (let ((commit "1b33dc252cfedfbb2107ea407266b168b71bebb1")
+        (revision "0"))
+    (package
+      (name "emacs-org-rss-publishing")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://git.sr.ht/~taingram/org-publish-rss")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0axz3r8jw15imhfmbriljsiaxiiqhgrq77nad3kmmgpmvhhlk65f"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-org))
+      (home-page "https://git.sr.ht/~taingram/org-publish-rss")
+      (synopsis "RSS generator for Org Mode's built-in publishing system")
+      (description "This package adds new RSS generation options to the
+@code{org-publish-project-alist} variable (see the Org manual if you are new to
+the publishing options). It adds @code{:auto-rss} and other options that work
+similar to the included @code{:auto-sitemap} functionality. This should make it
+easy for users to add RSS feeds to existing Org-based websites.")
+      (license license:gpl3))))
+
 (define-public emacs-blimp
   (let ((commit "e420763d6d18b5d1be552cdbc47f91418343db03"))
     (package