diff mbox series

[bug#68182] gnu: emacs-ggtags: Update to 0.9.0-0.4e3630c.

Message ID e88472cea88a10a839dc1f10387262eeb4ccb820.1704042348.git.csantosb@inventati.org
State New
Headers show
Series [bug#68182] gnu: emacs-ggtags: Update to 0.9.0-0.4e3630c. | expand

Commit Message

Cayetano Santos Dec. 31, 2023, 5:05 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-ggtags): Update to 0.9.0-0.4e3630c.

Signed-off-by: Cayetano Santos <csantosb@inventati.org>
---
 gnu/packages/emacs-xyz.scm | 58 ++++++++++++++++++++------------------
 1 file changed, 31 insertions(+), 27 deletions(-)


base-commit: f24b14767d362a84e6469682b4fe303b50f4b589
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6bec2bca46..4e6cc15286 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4947,32 +4947,36 @@  (define-public emacs-xcscope
       (license license:gpl2+))))
 
 (define-public emacs-ggtags
-  (package
-    (name "emacs-ggtags")
-    (version "0.9.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://elpa.gnu.org/packages/ggtags-"
-                           version ".tar"))
-       (sha256
-        (base32
-         "0p79x9g94jynl83ndvqp9349vhgkzxzhnc517r8hn44iqxqf6ghg"))))
-    (build-system emacs-build-system)
-    (inputs
-     (list global))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'configure
-           (lambda* (#:key inputs #:allow-other-keys)
-             (chmod "ggtags.el" #o644)
-             (emacs-substitute-variables "ggtags.el"
-               ("ggtags-executable-directory"
-                (dirname (search-input-file inputs "bin/global")))))))))
-    (home-page "https://github.com/leoliu/ggtags")
-    (synopsis "Frontend to the GNU Global source code tagging system")
-    (description "@code{ggtags} provides a frontend to the GNU Global source
+  (let ((commit "4e3630c30fb836872b5d8f2ae3e5d5ae003365d8")
+        (revision "0"))
+    (package
+      (name "emacs-ggtags")
+      (version (git-version "0.9.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/leoliu/ggtags")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1mgdli2kvsg3y6ynsl6547cwwg9f2q0s1cv4b74slpcvq5n1kb90"))))
+      (build-system emacs-build-system)
+      (inputs
+       (list global))
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'configure
+             (lambda* (#:key inputs #:allow-other-keys)
+               (chmod "ggtags.el" #o644)
+               (emacs-substitute-variables "ggtags.el"
+                 ("ggtags-executable-directory"
+                  (dirname (search-input-file inputs "bin/global")))))))))
+      (home-page "https://github.com/leoliu/ggtags")
+      (synopsis "Frontend to the GNU Global source code tagging system")
+      (description "@code{ggtags} provides a frontend to the GNU Global source
 code tagging system.
 
 Features:
@@ -5000,7 +5004,7 @@  (define-public emacs-ggtags
 @item Support eldoc.
 @item Search @code{GTAGSLIBPATH} for references and symbols.
 @end itemize\n")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-go-mode
   ;; XXX: Upstream did not tag last release.  The commit below matches version