diff mbox series

[bug#39108] gnu: Add gst-editing-services.

Message ID e8689402a142c424bfe780402d4accb943fc62f6.camel@student.tugraz.at
State Accepted
Headers show
Series [bug#39108] gnu: Add gst-editing-services. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Leo Prikler Feb. 14, 2020, 4:42 p.m. UTC
Am Freitag, den 14.02.2020, 17:12 +0100 schrieb Marius Bakke:
> I'm getting a strange build failure with this patch:
> 
> 
> ...
> Dependency gstreamer-plugins-base-1.0 found: YES 1.16.2
> Dependency gstreamer-plugins-bad-1.0 found: NO (tried pkgconfig and
> cmake)
> 
> tests/check/meson.build:41:2: ERROR: 'not-found' is not a pkgconfig
> dependency
> 
> A full log can be found at /tmp/guix-build-gst-editing-services-
> 1.16.2.drv-0/build/meson-logs/meson-log.txt
> 
> I suppose it needs 'gst-plugins-bad'?
Indeed, it does, though interestingly just for tests, which are
currently broken.  I already had this back when I tried meson, but have
since forgot about it.  There are no actual references to it, so I've
made it a native input.  As far as using it is concerned, I think one
might be able to do without a certain set of plugins depending on the
codecs used.  Either way, I'm not really sure whether it should
propagate the main plugin set.

I also added the good plugins even if they are not mentioned, just to
be on the safe side.

Comments

Marius Bakke Feb. 14, 2020, 4:51 p.m. UTC | #1
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> Am Freitag, den 14.02.2020, 17:12 +0100 schrieb Marius Bakke:
>> I'm getting a strange build failure with this patch:
>> 
>> 
>> ...
>> Dependency gstreamer-plugins-base-1.0 found: YES 1.16.2
>> Dependency gstreamer-plugins-bad-1.0 found: NO (tried pkgconfig and
>> cmake)
>> 
>> tests/check/meson.build:41:2: ERROR: 'not-found' is not a pkgconfig
>> dependency
>> 
>> A full log can be found at /tmp/guix-build-gst-editing-services-
>> 1.16.2.drv-0/build/meson-logs/meson-log.txt
>> 
>> I suppose it needs 'gst-plugins-bad'?
> Indeed, it does, though interestingly just for tests, which are
> currently broken.  I already had this back when I tried meson, but have
> since forgot about it.  There are no actual references to it, so I've
> made it a native input.  As far as using it is concerned, I think one
> might be able to do without a certain set of plugins depending on the
> codecs used.  Either way, I'm not really sure whether it should
> propagate the main plugin set.
>
> I also added the good plugins even if they are not mentioned, just to
> be on the safe side.  

OK.  I changed the TODO to a FIXME and added a copyright line for you.

Pushed in 64fc4f3705423c83c680a95d8dea81a39fce9a70, thanks!
diff mbox series

Patch

From f9a9c7dec9681cf7d5d646df96cbbe19f98e5de2 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Sun, 12 Jan 2020 18:42:24 +0100
Subject: [PATCH] gnu: Add gst-editing-services.

* gnu/packages/gstreamer.scm (gst-editing-services): New variable.
---
 gnu/packages/gstreamer.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 1e26a3c..0c824e0 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -476,6 +476,39 @@  distribution problems in some jurisdictions, e.g. due to patent threats.")
 compression formats through the use of the libav library.")
     (license license:gpl2+)))
 
+(define-public gst-editing-services
+  (package
+    (name "gst-editing-services")
+    (version "1.16.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://gstreamer.freedesktop.org/src/" name "/"
+                    "gstreamer-editing-services-" version ".tar.xz"))
+              (sha256
+               (base32
+                "05hcf3prna8ajjnqd53221gj9syarrrjbgvjcbhicv0c38csc1hf"))))
+    (build-system meson-build-system)
+    (arguments
+     ;; TODO: 16/22 failing tests
+     `(#:tests? #f))
+    (inputs
+     `(("gst-plugins-base" ,gst-plugins-base)
+       ("libxml2" ,libxml2)))
+    (native-inputs
+     `(("flex" ,flex)
+       ("gst-plugins-bad" ,gst-plugins-bad)
+       ("gst-plugins-good" ,gst-plugins-good)
+       ("perl" ,perl)
+       ("pkg-config" ,pkg-config)
+       ("python" ,python)))
+    (home-page "https://gstreamer.freedesktop.org/")
+    (synopsis "GStreamer library for non-linear editors")
+    (description
+     "This is a high-level library for facilitating the creation of audio/video
+non-linear editors.")
+    (license license:gpl2+)))
+
 (define-public python-gst
   (package
     (name "python-gst")
--
libgit2 0.28.4