diff mbox series

[bug#69377,v2] gnu: Add sioyek.

Message ID e852531eb0702ea1ab816eb69ab36ae63d016e72.1708884262.git.i@dan.games
State New
Headers show
Series [bug#69377,v2] gnu: Add sioyek. | expand

Commit Message

dan Feb. 25, 2024, 6:08 p.m. UTC
* gnu/packages/pdf.scm (sioyek): New variable.

Change-Id: Id2708745bd7ef672b620b8e9c907126bdc5a1f55
---
 gnu/packages/pdf.scm | 56 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 56 insertions(+)


base-commit: b25b94335a3ee8d68d2145da8e5ea0325ecea451
diff mbox series

Patch

diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 0d796f65bb..553642c170 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -25,6 +25,7 @@ 
 ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2023 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2024 dan <i@dan.games>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1710,3 +1711,58 @@  (define-public weasyprint
 
 Keywords: html2pdf, htmltopdf")
     (license license:bsd-3)))
+
+(define-public sioyek
+  (package
+    (name "sioyek")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ahrm/sioyek")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "1vmmp2s032ygh1byz77pg9aljmp8hx745fr7mmz11831f96mlmhq"))
+       (modules '((guix build utils)))
+       (snippet '(substitute* "pdf_viewer_build_config.pro"
+                   (("-lmupdf-third")
+                    "")))
+       ;; XXX: Fix for mupdf-0.23.0+ <https://github.com/ahrm/sioyek/issues/804>.
+       (patches (search-patches "sioyek-mupdf-0.23.0-fix-build.patch"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:configure-flags #~(list (string-append "PREFIX="
+                                               #$output))
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'patch-paths
+                     (lambda _
+                       (substitute* "pdf_viewer/main.cpp"
+                         (("/usr/share")
+                          (string-append #$output "/share"))
+                         (("/etc")
+                          (string-append #$output "/etc")))))
+                   (replace 'configure
+                     (lambda* (#:key configure-flags #:allow-other-keys)
+                       (apply invoke "qmake" configure-flags)))
+                   (add-after 'install 'instal-man-page
+                     (lambda _
+                       (install-file "resources/sioyek.1"
+                                     (string-append #$output "/share/man/man1")))))))
+    (inputs (list freetype
+                  gumbo-parser
+                  harfbuzz
+                  jbig2dec
+                  libjpeg-turbo
+                  mujs
+                  mupdf
+                  openjpeg
+                  qt3d-5
+                  qtbase-5
+                  zlib))
+    (home-page "https://sioyek.info")
+    (synopsis "PDF viewer with a focus on technical books and research papers")
+    (description
+     "Sioyek is a PDF viewer with a focus on textbooks and research papers.")
+    (license license:gpl3+)))