diff mbox series

[bug#49909] gnu: Add emacs-placeholder.

Message ID e7f3c72449258f6e3b2745b3ed73b92d5a2db781.1628243631.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#49909] gnu: Add emacs-placeholder. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen Aug. 6, 2021, 9:54 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-placeholder): New variable.
---
 gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: ead6cc03c66ed31f0ab7300fab11cef3a1e459f0

Comments

Nicolas Goaziou Aug. 13, 2021, 1:56 p.m. UTC | #1
Hello,

Xinglu Chen <public@yoctocell.xyz> writes:

> * gnu/packages/emacs-xyz.scm (emacs-placeholder): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9cbd99b7b1..2f275fad9b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28156,6 +28156,35 @@  provides a simple but convenient user interface to manage those trashed
 files.")
     (license license:gpl3+)))
 
+(define-public emacs-placeholder
+  ;; No tags.
+  (let ((commit "b80cb152ddd63db40cc581eafee9d2ac08328df8"))
+    (package
+      (name "emacs-placeholder")
+      (version "0.1")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/oantolin/placeholder")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1ifiaxrp7inj70a3zf5137dih4b1sw38zmkp3h7dj79k2bv7h34h"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/oantolin/placeholder")
+      (synopsis "Treat any buffer as a template with placeholders to fill-in")
+      (description
+       "This package provides a simple way to treat text in a buffer as a template
+with placeholders where text needs to be filled in.  Any occurrence of
+@code{<++>} in the buffer is a placeholder.  You can navigate among the
+placeholder with the placeholder-forward and placeholder-backward commands.
+They move the point to the next placeholder in the specified direction and
+delete the placeholder so you can immediately start typing the text that
+should replace it.  However, if you call them again immediately after, they
+restore that occurrence of the placeholder and move to the next.")
+      (license license:gpl3+))))
+
 (define-public emacs-plantuml-mode
   (package
     (name "emacs-plantuml-mode")