[bug#78246,v2] gnu: Add symfpu.
Commit Message
From: Sören Tempel <soeren@soeren-tempel.net>
* gnu/packages/maths.scm (symfpu): New variable.
---
Change since v2:
* Make revision let-bound
* Fix git-version
* Use an install-plan
* Change license to gpl3+
gnu/packages/maths.scm | 48 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)
base-commit: 415e3d98d6faf5fd3d1b7b3daa2f20636e4ff822
@@ -8218,6 +8218,54 @@ (define-public yices
s-expression-based format.")
(license license:gpl3+)))
+(define-public symfpu
+ (let ((commit "22d993d880f66b2e470c3928e0e61bdf61419702")
+ (revision "0"))
+ (package
+ (name "symfpu")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/martin-cs/symfpu")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h20zzkyi225290kc6mzg8i4dwkj0p1vlwfgc9ycs61snlyd8gr8"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan
+ #~`(("symfpu.pc" "lib/pkgconfig/symfpu.pc")
+ ("core" "include/symfpu/core")
+ ("utils" "include/symfpu/utils"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'build-pkgconfig
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-output-to-file "symfpu.pc"
+ (lambda _
+ (format #t
+ "prefix=~a~@
+ exec_prefix=${prefix}~@
+ includedir=${prefix}/include~@
+ ~@
+ ~@
+ Name: symfpu~@
+ Version: ~a~@
+ Description: library for IEEE-754 floats~@
+ Cflags: -I${includedir}~%"
+ (assoc-ref outputs "out")
+ #$version))))))))
+ (synopsis
+ "Concrete and symbolic implementation of IEEE-754 floating-point numbers")
+ (description
+ "This library provides a C++ implementation of concrete and symbolic semantics
+for floating point numbers as defined in IEEE Standard for Floating-Point Arithmetic.")
+ (home-page "https://github.com/martin-cs/symfpu")
+ (license license:gpl3+))))
+
(define-public z3
(package
(name "z3")