diff mbox series

[bug#56729,RFC,v3,18/32] gnu: pari-gp: Use G-expression.

Message ID e761db2ef69d834df512dd2c97af07e4335fca36.1685391447.git.guix@ikherbers.com
State New
Headers show
Series None | expand

Commit Message

vicvbcun May 29, 2023, 8:38 p.m. UTC
* gnu/packages/algebra.scm (pari-gp)[arguments]: Convert to gexp.
---
 gnu/packages/algebra.scm | 19 +++++++++----------
 1 file changed, 9 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index ee08378058..0b238d6f4b 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -274,16 +274,15 @@  (define-public pari-gp
                           (list texlive-amsfonts))))
     (inputs (list gmp libx11 perl readline))
     (arguments
-     '(#:make-flags '("all")
-       #:test-target "dobench"
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda* (#:key outputs #:allow-other-keys)
-             (invoke "./Configure"
-                     "--mt=pthread"
-                     (string-append "--prefix="
-                                    (assoc-ref outputs "out"))))))))
+     (list #:make-flags '(list "all")
+           #:test-target "dobench"
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'configure
+                 (lambda _
+                   (invoke "./Configure"
+                           "--mt=pthread"
+                           (string-append "--prefix=" #$output)))))))
     (synopsis "PARI/GP, a computer algebra system for number theory")
     (description
      "PARI/GP is a widely used computer algebra system designed for fast