diff mbox series

[bug#50425] gnu: Add minetest-advtrains.

Message ID e7485e6dbbafc68831f37ebd09062f85fd734896.camel@planete-kraus.eu
State Accepted
Headers show
Series [bug#50425] gnu: Add minetest-advtrains. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vivien Kraus Sept. 7, 2021, 10:45 a.m. UTC
Hello Maxime,

Le mardi 07 septembre 2021 à 12:20 +0200, Maxime Devos a écrit :
> The indentation from "./etc/indent-code.el" should be good.  Feel
> free
> to precedede the ‘gnu: Add minetest-advtrains’ patch with a patch
> fixing
> the indentation.

Since the indentation only changed for 2 packages, I made 2 commits,
one for each package. This amounts to 3 commits (they should commute):
1. Fix indentation for minetest-data;
2. Fix indentation for minetest-mesecons;
3. Add minetest-advtrains.

Vivien

Comments

M Sept. 10, 2021, 10:25 a.m. UTC | #1
Hi,

Presuming minetest-advtrains and minetest-basic-trains build and actually
work, this largely LGTM.  I looked at the source code of advtrains and basic_trains
and didn't find anything ‘suspicious’ (e.g. malware, though mods are sandboxed
so they would have a hard time doing anything bad). 

minetest-advtrains and minetest-basic-trains are separate packages that
can be added separately, so theoretically, they should be added in separate
patches:

From (guix)Submitting Patches:
  11. Verify that your patch contains only one set of related changes.
     Bundling unrelated changes together makes reviewing harder and
     slower.

(minetest-advtrains seems rather useless without minetest-basic-trains though,
so maybe it's ok?)

Vivien Kraus schreef op di 07-09-2021 om 12:45 [+0200]:
> +(define-public minetest-advtrains
> +  (package
> +    (name "minetest-advtrains")
> +    (version "2.3.1")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://git.bananach.space/advtrains.git")
> +             (commit "release-2.3.1")))
> +       (sha256
> +        (base32 "1ijqlchh269jpvmgmdmdvy3nsnk0bszkvvcqk6vaysvxam695ggw"))
> +       (file-name (git-file-name name version))))
> +    (build-system minetest-mod-build-system)
> +    (home-page "http://advtrains.de/")
> +    (synopsis
> +     "Adds good-looking, realistic trains with realistic rails.")
> +    (description
> +     "This mod features realistic trains and various equipment for railways, with a focus on automated train operation.

Aren't the actual trains added with minetest-basic-trains?
Maybe replace ‘realistic trains’ -> ‘realistic train system’,
and note that minetest-basic-trains contains the actual train models.

I think a linter will have something to say about long lines here
(try "./pre-inst-env guix lint minetest-advtrains minetest-basic-trains").

> +
> +Main features:
> +
> +@itemize
> +@item
> +almost-realistic tracks with actual curves and switches;
> +@item
> +railway signals, controllable by various means;
> +@item
> +ATC: simple, command-like automatic train control;
> +@item
> +LuaATC: Powerful Lua-scripted automatic train operation (requires some programming knowledge);
> +@item
> +an interlocking system, featuring track sections, routes and automatic stopping before signals.
> +@end itemize")

Greetings,
Maxime.
diff mbox series

Patch

From a97f8395a685b688b240f28089f368b9065d1d61 Mon Sep 17 00:00:00 2001
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Tue, 7 Sep 2021 12:27:59 +0200
Subject: [PATCH 1/3] gnu: minetest-data: Fix indentation.

* gnu/packages/minetest.scm (minetest-data): Fix indentation.
---
 gnu/packages/minetest.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 5453f4d16a..6f4682ba47 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -154,8 +154,8 @@  in different ways.")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                     (url "https://github.com/minetest/minetest_game")
-                     (commit version)))
+                    (url "https://github.com/minetest/minetest_game")
+                    (commit version)))
               (file-name (git-file-name name version))
               (sha256
                (base32
@@ -172,8 +172,8 @@  in different ways.")
                                        "/share/minetest/games/minetest_game")))
                      (mkdir-p install-dir)
                      (copy-recursively
-                       (assoc-ref %build-inputs "source")
-                       install-dir)
+                      (assoc-ref %build-inputs "source")
+                      install-dir)
                      #t))))
     (synopsis "Main game data for the Minetest game engine")
     (description
-- 
2.33.0