diff mbox series

[bug#36059] gnu: GParted: Update 1.0.0.

Message ID e7003de5fa3105d41656927035c92e8599677247.1559506257.git.leo@famulari.name
State Accepted
Headers show
Series [bug#36059] gnu: GParted: Update 1.0.0. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Leo Famulari June 2, 2019, 8:12 p.m. UTC
This update includes some changes to how the documentation is built. The
GParted help system does not work for me in either this new version or
the previous one, but I am not using GNOME. Can some GNOME user review
this patch, especially checking if there is a regression in accessing
the help pages?

Release notes:

https://sourceforge.net/projects/gparted/files/gparted/gparted-1.0.0/gparted-1.0.0-README.md/view

* gnu/packages/disk.scm (gparted): Update to 1.0.0.
[arguments]: Remove obsolete configure flag.
[inputs]: Use gtkmm@3. Add yelp-tools and itstool. Remove libxslt,
gnome-doc-utils, docbook-xml-4.2, python-2, python2-libxml2, and which.
[native-inputs]: Add lvm2.
---
 gnu/packages/disk.scm | 22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)

Comments

Ludovic Courtès June 5, 2019, 3:14 p.m. UTC | #1
Hi,

Leo Famulari <leo@famulari.name> skribis:

> This update includes some changes to how the documentation is built. The
> GParted help system does not work for me in either this new version or
> the previous one, but I am not using GNOME. Can some GNOME user review
> this patch, especially checking if there is a regression in accessing
> the help pages?
>
> Release notes:
>
> https://sourceforge.net/projects/gparted/files/gparted/gparted-1.0.0/gparted-1.0.0-README.md/view
>
> * gnu/packages/disk.scm (gparted): Update to 1.0.0.
> [arguments]: Remove obsolete configure flag.
> [inputs]: Use gtkmm@3. Add yelp-tools and itstool. Remove libxslt,
> gnome-doc-utils, docbook-xml-4.2, python-2, python2-libxml2, and which.
> [native-inputs]: Add lvm2.

I can’t comment about the GNOME Help issue, but otherwise the patch
LGTM.

Thanks!

Ludo’.
Leo Famulari June 12, 2019, 7:47 p.m. UTC | #2
On Wed, Jun 05, 2019 at 05:14:01PM +0200, Ludovic Courtès wrote:
> I can’t comment about the GNOME Help issue, but otherwise the patch
> LGTM.
> 
> Thanks!

Okay, pushed as ff22ff42a1d759eafd94e596c7a610e8fd9eb001

Thanks for the review!
diff mbox series

Patch

diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 491f7ce881..778529436b 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -13,6 +13,7 @@ 
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -341,32 +342,31 @@  and can dramatically shorten the lifespan of the drive if left unchecked.")
 (define-public gparted
   (package
     (name "gparted")
-    (version "0.33.0")
+    (version "1.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://sourceforge/gparted/gparted/gparted-"
                            version "/gparted-" version ".tar.gz"))
        (sha256
-        (base32 "1ml1ky3s75lbxr91p608q3prsdh9x899mw7nbgk252pqhg4vh8sh"))))
+        (base32
+         "0mdvn85jvy72ff7nds3dakx9kzknh8gx1z8i0w2sf970q03qp2z4"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ; tests require a network connection
-       #:configure-flags '("--disable-scrollkeeper")))
+      ;; Tests require access to paths outside the build container, such
+      ;; as '/dev/disk/by-id'
+     `(#:tests? #f))
     (inputs
      `(("util-linux" ,util-linux)
        ("parted" ,parted)
        ("glib" ,glib)
-       ("gtkmm" ,gtkmm-2)
+       ("gtkmm" ,gtkmm)
        ("libxml2" ,libxml2)
-       ("libxslt" ,libxslt)
-       ("gnome-doc-utils" ,gnome-doc-utils)
-       ("docbook-xml" ,docbook-xml-4.2)
-       ("python" ,python-2)
-       ("python-libxml2" ,python2-libxml2)
-       ("which" ,which)))
+       ("yelp-tools" ,yelp-tools)
+       ("itstool" ,itstool)))
     (native-inputs
      `(("intltool" ,intltool)
+       ("lvm2" ,lvm2) ; for tests
        ("pkg-config" ,pkg-config)))
     (home-page "https://gparted.org/")
     (synopsis "Partition editor to graphically manage disk partitions")