diff mbox series

[bug#61941,1/2] gnu: emacs-helpful: Update to 0.20.1c98f6f.

Message ID e6cad85daceaf8c46930268efce34f2fa7e96bf9.1677862554.git.contact@conses.eu
State New
Headers show
Series [bug#61941,1/2] gnu: emacs-helpful: Update to 0.20.1c98f6f. | expand

Commit Message

Miguel Ángel Moreno March 3, 2023, 4:58 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.20.1c98f6f.
[source]: Remove fix-docstring-test.patch.
[propagated-inputs]: Remove emacs-shut-up.
---
 gnu/packages/emacs-xyz.scm | 52 +++++++++++++++++++-------------------
 1 file changed, 26 insertions(+), 26 deletions(-)

Comments

Nicolas Goaziou March 8, 2023, 2:57 p.m. UTC | #1
Hello,

conses <contact@conses.eu> writes:

> * gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.20.1c98f6f.
> [source]: Remove fix-docstring-test.patch.
> [propagated-inputs]: Remove emacs-shut-up.

Thank you. Some comments follow.

> +  (let ((commit "1c98f6f06a85def5d34c735f8cd407f20cebddf9")
> +        (revision "0"))

Is there a particular reason to use an unreleased version?

> +    (package
> +      (name "emacs-helpful")
> +      (version (git-version "0.20" revision commit))

Base version is actually still 0.19. Upstream bumped Version keyword,
but the README mentions there is no official 0.20 yet. I suggest to
stick to 0.19.

> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/Wilfred/helpful")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "18b5hjfji51zxjrxhkklxx3j9svk295awmxv8n95mp8ilas2kd3l"))))
> +      (build-system emacs-build-system)
> +      (propagated-inputs
> +       (list emacs-elisp-refs emacs-dash emacs-s emacs-f))

While you're at it, could you re-order inputs alphabetically?

You can also merge both patches.

Regards,
Miguel Ángel Moreno March 9, 2023, 10:47 p.m. UTC | #2
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

>> +  (let ((commit "1c98f6f06a85def5d34c735f8cd407f20cebddf9")
>> +        (revision "0"))
>
> Is there a particular reason to use an unreleased version?
>

The latest release was over two years ago and a lot of functionality has
been added.

>> +    (package
>> +      (name "emacs-helpful")
>> +      (version (git-version "0.20" revision commit))
>
> Base version is actually still 0.19. Upstream bumped Version keyword,
> but the README mentions there is no official 0.20 yet. I suggest to
> stick to 0.19.
>

Ok, will send a revised patch.

>> +      (source
>> +       (origin
>> +         (method git-fetch)
>> +         (uri (git-reference
>> +               (url "https://github.com/Wilfred/helpful")
>> +               (commit commit)))
>> +         (file-name (git-file-name name version))
>> +         (sha256
>> +          (base32 "18b5hjfji51zxjrxhkklxx3j9svk295awmxv8n95mp8ilas2kd3l"))))
>> +      (build-system emacs-build-system)
>> +      (propagated-inputs
>> +       (list emacs-elisp-refs emacs-dash emacs-s emacs-f))
>
> While you're at it, could you re-order inputs alphabetically?
>
> You can also merge both patches.
>

Sure.  Thanks for having a look!

> Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3f7fcf4481..a3535728f8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23126,31 +23126,31 @@  (define-public emacs-download-region
       (license license:gpl3+))))
 
 (define-public emacs-helpful
-  (package
-    (name "emacs-helpful")
-    (version "0.19")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/Wilfred/helpful")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0qwsifzsjw95l83m7z07fr9h1sqbhggwmcps1qgbddpan2a8ab8a"))
-       ;; Cherry-picked from upstream, remove when bumping to 0.20.
-       (patches (search-patches "emacs-helpful-fix-docstring-test.patch"))))
-    (build-system emacs-build-system)
-    (propagated-inputs
-     (list emacs-elisp-refs emacs-dash emacs-s emacs-f emacs-shut-up))
-    (native-inputs
-     (list emacs-ert-runner emacs-undercover))
-    (arguments
-     `(#:tests? #t
-       #:test-command '("ert-runner")))
-    (home-page "https://github.com/Wilfred/helpful")
-    (synopsis "More contextual information in Emacs help")
-    (description "@code{helpful} is an alternative to the built-in Emacs help
+  (let ((commit "1c98f6f06a85def5d34c735f8cd407f20cebddf9")
+        (revision "0"))
+    (package
+      (name "emacs-helpful")
+      (version (git-version "0.20" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Wilfred/helpful")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "18b5hjfji51zxjrxhkklxx3j9svk295awmxv8n95mp8ilas2kd3l"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       (list emacs-elisp-refs emacs-dash emacs-s emacs-f))
+      (native-inputs
+       (list emacs-ert-runner emacs-undercover))
+      (arguments
+       `(#:tests? #t
+         #:test-command '("ert-runner")))
+      (home-page "https://github.com/Wilfred/helpful")
+      (synopsis "More contextual information in Emacs help")
+      (description "@code{helpful} is an alternative to the built-in Emacs help
 that provides much more contextual information.
 
 @itemize
@@ -23169,7 +23169,7 @@  (define-public emacs-helpful
 @item Trace, disassemble functions from inside Helpful.  This is discoverable
 and doesn't require memorisation of commands.
 @end itemize\n")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-logview
   (package