diff mbox series

[bug#42380,v4,5/9] gnu: Add go-github-com-dsnet-compress.

Message ID e6be05ea33f1acae969c44a8426e7953735e57ae.1622687706.git.nandre@riseup.net
State New
Headers show
Series [bug#42380,v4,1/9] gnu: Add go-torproject-org-ptlib. | expand

Commit Message

André Batista June 3, 2021, 3:17 a.m. UTC
* gnu/packages/golang.scm (go-github-com-dsnet-compress): New variable.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 08b5b6ba9b..f554a8305e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7148,3 +7148,29 @@  J. Bernstein. ")
      (description "Package uniuri generates random strings good for use in
 Universal Resource Identifiers to uniquely identify objects.")
      (license license:cc0))))
+
+(define-public go-github-com-dsnet-compress
+  (let ((commit "cc9eb1d7ad760af14e8f918698f745e80377af4f")
+        (revision "0"))
+    (package
+     (name "go-github-com-dsnet-compress")
+     (version (git-version "0.0.0" revision commit))
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dsnet/compress")
+             (commit commit)))
+       (file-name (string-append name "-" version "-checkout"))
+       (sha256
+        (base32
+         "159liclywmyb6zx88ga5gn42hfl4cpk1660zss87fkx31hdq9fgx"))))
+     (build-system go-build-system)
+     (arguments
+      '(#:import-path "github.com/dsnet/compress"))
+     (home-page "https://github.com/dsnet/compress")
+     (synopsis "Go library for extended compression")
+     (description "This is a collection of compression related libraries.
+The goal of this project is to provide pure Go implementations for popular
+compression algorithms bey ond what the Go standard library provides.")
+     (license (license:non-copyleft "file://LICENSE.md")))))