diff mbox series

[bug#39213] gnu: Add regrader.

Message ID e6af58298cd8d5419ad67c1f9dea5c76b7a202bd.camel@zrythm.org
State Accepted
Headers show
Series [bug#39213] gnu: Add regrader. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou Jan. 21, 2020, 5:36 a.m. UTC
Simplified by inheriting since it uses the exact same build procedure
and dependencies as vl1-emulator by the same upstream.

Thanks,
Alex
diff mbox series

Patch

From 345b974a8dc783aa03c2bfd77c1e8dffba284639 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 21 Jan 2020 05:19:03 +0000
Subject: [PATCH] gnu: Add regrader.

* gnu/packages/music.scm (regrader): New variable.
---
 gnu/packages/music.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5e6509e6ca..90774eafe7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5163,3 +5163,29 @@  code by PolyValens, offered as a VST plugin, an LV2 plugin and a standalone
 JACK application.")
     ;; Expat or CC0
     (license (list license:expat license:cc0))))
+
+(define-public regrader
+  (package
+    (inherit vl1-emulator)
+    (name "regrader")
+    (version "1.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/linuxmao-org/regrader.git")
+               (commit (string-append "v" version))
+               ;; bundles a specific commit of the DISTRHO plugin framework
+               (recursive? #t)))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "0gl4d5lf2afqknz22jz7hh7029sc9v1xrz6nbz9dlv42bwc0cvl0"))))
+    (home-page "https://github.com/linuxmao-org/regrader")
+    (synopsis "Delay effect plugin")
+    (description
+     "Regrader is a delay effect where the repeats degrade in resolution.
+This is an unofficial port of the Regrader plugin created by Igorski.  It
+is available as an LV2 plugin, a VST plugin and a standalone JACK
+application.")
+    (license license:expat)))
-- 
2.24.1