[bug#75032,09/13] gnu: Add palp.

Message ID e6a978a83ce83868be007b35288065e9458b20af.1734887844.git.monego@posteo.net
State New
Headers
Series Add more SageMath packages |

Commit Message

Vinicius Monego Dec. 22, 2024, 5:26 p.m. UTC
  From: vicvbcun <guix@ikherbers.com>

* gnu/packages/maths.scm (palp): New variable.

Change-Id: I37ee870858fef505999dfdc02d1955673366d718
Co-authored by: Vinicius Monego <monego@posteo.net>

Change-Id: I853cbccca5c34355d9df74a3cbbd5f818a21ebb5
---
 gnu/packages/maths.scm | 35 +++++++++++++++++++++++++++++++++--
 1 file changed, 33 insertions(+), 2 deletions(-)
  

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 35de236ba2..e89c17a2c0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5573,6 +5573,37 @@  (define-public libblastrampoline
 library.")
     (license license:expat)))
 
+(define-public palp
+  (package
+    (name "palp")
+    (version "2.21")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://hep.itp.tuwien.ac.at/~kreuzer/CY/palp/palp-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1myxjv0jxgr9acchwnjh9g5l61wxwiva3q6c1d6892lr37r7njky"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:make-flags #~(list (string-append "CC=" #$(cc-for-target)))
+           #:tests? #f ; no tests
+           #:phases #~(modify-phases %standard-phases
+                        (delete 'configure)
+                        (replace 'install
+                          (lambda _
+                            (for-each
+                             (lambda (name)
+                               (install-file name (string-append #$output "/bin")))
+                             '("class.x" "cws.x" "mori.x" "nef.x" "poly.x")))))))
+    (home-page "http://hep.itp.tuwien.ac.at/~kreuzer/CY/CYpalp.html")
+    (synopsis "Package for Analyzing Lattice Polytopes")
+    (description
+     "PALP is a set of programs for calculations with lattice polytopes and
+applications to toric geometry.")
+    (license license:gpl3)))
+
 (define-public blis
   (package
     (name "blis")
@@ -5600,9 +5631,9 @@  (define-public blis
       #~(modify-phases %standard-phases
           (replace 'configure
             (lambda* (#:key outputs target system (configure-flags '())
-                      #:allow-other-keys)
+                            #:allow-other-keys)
               ;; This is a home-made 'configure' script.
-              (let* (;; Guix-specific support for choosing the configuration
+              (let* ( ;; Guix-specific support for choosing the configuration
                      ;; via #:configure-flags: see below for details.
                      (config-flag-prefix "--blis-config=")
                      (maybe-config-flag (find