diff mbox series

[bug#54299,v2,01/25] gnu: rust-structopt-derive-0.4: Update to 0.4.18.

Message ID e6Wd6fbbqiWLx2cHSVfViNJ7CMlyUDkKjDpj-qmYO-BJ8o0whvsa3UwAtw0ndvlvJFeFveiQQflDtcClaXAslxZtB7lVlH95JpGGkxWc_q8=@protonmail.com
State New
Headers show
Series [bug#54299,v2,01/25] gnu: rust-structopt-derive-0.4: Update to 0.4.18. | expand

Commit Message

phodina April 24, 2022, 12:55 p.m. UTC
Hi,

here are patches that almost build alacritty. In alacritty package there is still phase (add-absolute-library-references) which fails.

There are patches for Cargo.toml to remove support for Android, IOS and Windows.

The downside of replacing rust-wayland-.*-0.28 with 0.29 is that there are some other packages that need to be updated or fix requirements in Cargo.toml.

I'll check what which regular inputs (or propagated-inputs maybe) might suffice instead of cargo-inputs.

Could someone please check what's wrong with the failing phase in the meantime?

----
Petr
diff mbox series

Patch

From d927e95c1f6da1a7af3310725a4bd04a0797ed25 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Sun, 24 Apr 2022 08:05:12 +0200
Subject: [PATCH v2 14/25] gnu: Add rust-wayland-server-0.29.

* gnu/packages/crates-graphics.scm (rust-wayland-server-0.29): New variable.
  (rust-wayland-server-0.23): Inherit from above.
  (rust-wayland-server-0.28): Remove variable.

diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index ffe8f9e52d..f2eaedf624 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2740,17 +2740,17 @@  (define-public rust-wayland-scanner-0.21
         (base32
          "17mp49v7w0p0x5ry628lj2llljnwkr9aj9g4bqqhfibid32jhf5z"))))))
 
-(define-public rust-wayland-server-0.28
+(define-public rust-wayland-server-0.29
   (package
     (name "rust-wayland-server")
-    (version "0.28.3")
+    (version "0.29.4")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "wayland-server" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "09jfdjfqhjfcpiz4csgh60ymfkmz1cl3jmxyzq9hzcp0kyyxix93"))))
+        (base32 "1wj8gf28dbjwb824i29wf3wr5r6wp6ssknjm9b5dnb1fah47mk66"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
@@ -2758,7 +2758,7 @@  (define-public rust-wayland-server-0.28
         ("rust-downcast-rs" ,rust-downcast-rs-1)
         ("rust-lazy-static" ,rust-lazy-static-1)
         ("rust-libc" ,rust-libc-0.2)
-        ("rust-nix" ,rust-nix-0.18)
+        ("rust-nix" ,rust-nix-0.22)
         ("rust-parking-lot" ,rust-parking-lot-0.11)
         ("rust-scoped-tls" ,rust-scoped-tls-1))))
     (inputs
@@ -2766,12 +2766,12 @@  (define-public rust-wayland-server-0.28
            rust-downcast-rs-1
            rust-lazy-static-1
            rust-libc-0.2
-           rust-nix-0.18
+           rust-nix-0.22
            rust-parking-lot-0.11
            rust-scoped-tls-1
-           rust-wayland-commons-0.28
-           rust-wayland-scanner-0.28
-           rust-wayland-sys-0.28))
+           rust-wayland-commons-0.29
+           rust-wayland-scanner-0.29
+           rust-wayland-sys-0.29))
     (home-page "https://github.com/smithay/wayland-rs")
     (synopsis
      "Bindings to the standard C implementation of the wayland protocol")
@@ -2782,7 +2782,7 @@  (define-public rust-wayland-server-0.28
 
 (define-public rust-wayland-server-0.23
   (package
-    (inherit rust-wayland-server-0.28)
+    (inherit rust-wayland-server-0.29)
     (name "rust-wayland-server")
     (version "0.23.6")
     (source
-- 
2.35.1