diff mbox series

[bug#68987,1/2] gnu: moonfish: Update to 0-2.2118580.

Message ID e64550fd3c8b6b0ba39c7484fc5a679787f99643.1707351996.git.zamfofex@twdb.moe
State New
Headers show
Series update moonfish | expand

Commit Message

zamfofex Feb. 8, 2024, 12:34 a.m. UTC
* gnu/packages/games.scm (moonfish): Update to 0-2.2118580.

Change-Id: I0c5b0e61f6818d29165a1371da717bb8695db834
---
 gnu/packages/games.scm | 50 ++++++++++++++----------------------------
 1 file changed, 17 insertions(+), 33 deletions(-)

Comments

Liliana Marie Prikler Feb. 8, 2024, 5:50 p.m. UTC | #1
Am Mittwoch, dem 07.02.2024 um 21:34 -0300 schrieb zamfofex:
> * gnu/packages/games.scm (moonfish): Update to 0-2.2118580.
> 
> Change-Id: I0c5b0e61f6818d29165a1371da717bb8695db834
> ---
>  gnu/packages/games.scm | 50 ++++++++++++++--------------------------
> --
>  1 file changed, 17 insertions(+), 33 deletions(-)
> 
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 06ba868f35..16e2ee828a 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -10557,46 +10557,30 @@ (define-public stockfish
>        (license license:gpl3+))))
>  
>  (define-public moonfish
> -  (let ((commit "4f8829009e8c26e6a878261e0bc4c7e7617ef6b6")
> -        (revision "1"))
> +  (let ((commit "2118580d6ab454e165c7a84de6a604f96bc73850")
> +        (revision "2"))
>      (package
>        (name "moonfish")
>        (version (git-version "0" revision commit))
> -      (source (origin
> -                (method git-fetch)
> -                (uri (git-reference
> -                      (url "https://git.sr.ht/~zamfofex/moonfish")
> -                      (commit commit)))
> -                (sha256
> -                 (base32
> -                 
> "1ksg42x9cyn3pbfryy9raqb355k47cqcisascpy157c3cgdr2z60"))
> -                (file-name (git-file-name name version))))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://git.sr.ht/~zamfofex/moonfish")
> +               (commit commit)))
> +         (sha256
> +          (base32
> "1vqnmk2mpqd9nfchrirj5g3v3nqyhj3204d6fn3sihc2iqp4zyrk"))
> +         (file-name (git-file-name name version))))
Please don't mix in cosmetic changes with semantic ones.  IMHO the
indentation is fine as-is.
>        (build-system gnu-build-system)
>        (arguments
>         (list
> -        #:make-flags
> -        #~(list (string-append "CC=" #$(cc-for-target)))
> -        #:tests? #f                     ;no check target
> -        #:phases
> -        #~(modify-phases %standard-phases
> -            (delete 'configure)         ;no configure script
> -            (replace 'install           ;no 'install' target
> -              (lambda _
> -                (let* ((out-bin (string-append #$output "/bin"))
> -                       (tools-bin (string-append #$output:tools
> "/bin"))
> -                       (tool (string-append tools-bin "/moonfish-
> ")))
> -                  (mkdir-p out-bin)
> -                  (mkdir-p tools-bin)
> -                  (copy-file "moonfish"
> -                             (string-append out-bin "/moonfish"))
> -                  (copy-file "play"
> -                             (string-append tool "play"))
> -                  (copy-file "lichess"
> -                             (string-append tool "lichess"))
> -                  (copy-file "analyse"
> -                             (string-append tool "analyse"))))))))
> +        #:make-flags #~(list (string-append "CC="
> +                                            #$(cc-for-target))
> +                             (string-append "PREFIX=" %output))
> +        #:tests? #f ;no check target
> +        #:phases #~(modify-phases %standard-phases
> +                     (delete 'configure)))) ;no configure script
You forgot to document this change…
>        (inputs (list bearssl cjson))
> -      (outputs '("out" "tools"))
… as well as this.
>        (home-page "https://git.sr.ht/~zamfofex/moonfish")
>        (synopsis "Simple chess engine written in C")
>        (description

Cheers
zamfofex Feb. 8, 2024, 11:34 p.m. UTC | #2
> Please don't mix in cosmetic changes with semantic ones.  IMHO the
> indentation is fine as-is.

Sure. I just ran ‘guix style’ on it before committing, I thought it would have been warranted. I can undo the changes it made, sure.

> […]
> You forgot to document this change…
> […]
> … as well as this.

Sure, I’ll do that and send a new patch soon! Thanks for reviewing.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 06ba868f35..16e2ee828a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10557,46 +10557,30 @@  (define-public stockfish
       (license license:gpl3+))))
 
 (define-public moonfish
-  (let ((commit "4f8829009e8c26e6a878261e0bc4c7e7617ef6b6")
-        (revision "1"))
+  (let ((commit "2118580d6ab454e165c7a84de6a604f96bc73850")
+        (revision "2"))
     (package
       (name "moonfish")
       (version (git-version "0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://git.sr.ht/~zamfofex/moonfish")
-                      (commit commit)))
-                (sha256
-                 (base32
-                  "1ksg42x9cyn3pbfryy9raqb355k47cqcisascpy157c3cgdr2z60"))
-                (file-name (git-file-name name version))))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://git.sr.ht/~zamfofex/moonfish")
+               (commit commit)))
+         (sha256
+          (base32 "1vqnmk2mpqd9nfchrirj5g3v3nqyhj3204d6fn3sihc2iqp4zyrk"))
+         (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (arguments
        (list
-        #:make-flags
-        #~(list (string-append "CC=" #$(cc-for-target)))
-        #:tests? #f                     ;no check target
-        #:phases
-        #~(modify-phases %standard-phases
-            (delete 'configure)         ;no configure script
-            (replace 'install           ;no 'install' target
-              (lambda _
-                (let* ((out-bin (string-append #$output "/bin"))
-                       (tools-bin (string-append #$output:tools "/bin"))
-                       (tool (string-append tools-bin "/moonfish-")))
-                  (mkdir-p out-bin)
-                  (mkdir-p tools-bin)
-                  (copy-file "moonfish"
-                             (string-append out-bin "/moonfish"))
-                  (copy-file "play"
-                             (string-append tool "play"))
-                  (copy-file "lichess"
-                             (string-append tool "lichess"))
-                  (copy-file "analyse"
-                             (string-append tool "analyse"))))))))
+        #:make-flags #~(list (string-append "CC="
+                                            #$(cc-for-target))
+                             (string-append "PREFIX=" %output))
+        #:tests? #f ;no check target
+        #:phases #~(modify-phases %standard-phases
+                     (delete 'configure)))) ;no configure script
       (inputs (list bearssl cjson))
-      (outputs '("out" "tools"))
       (home-page "https://git.sr.ht/~zamfofex/moonfish")
       (synopsis "Simple chess engine written in C")
       (description