diff mbox series

[bug#62993] gnu: Add emacs-bookmark-plus

Message ID e62afb73b971f2b41cb7395e623088f12003420d.1682082880.git.kyle@posteo.net
State New
Headers show
Series [bug#62993] gnu: Add emacs-bookmark-plus | expand

Commit Message

kyle April 21, 2023, 1:14 p.m. UTC
From: Kyle Andrews <kyle@posteo.net>

---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Nicolas Goaziou April 21, 2023, 2:05 p.m. UTC | #1
Hello,

kyle <kyle@posteo.net> writes:

> +(define-public emacs-bookmark-plus
> +  (package
> +   (name "emacs-bookmark-plus")
> +   (version "2022.11.05")
> +   (source
> +    (origin
> +      (method git-fetch)
> +      (uri (git-reference
> +	    (url "https://github.com/emacsmirror/bookmark-plus")
> +	    (commit "3db369056a722c42b3eafd10a91831f87d056dfa")))
> +      (sha256
> +       (base32
> +	"0fnq24f597zfr8jj5h3vr87kdil5lhy11m81q6ayqc03qm0jymrf"))))

Nitpick: indentation is a bit off here.

> +   (build-system emacs-build-system)
> +   (home-page "https://github.com/emacsmirror/bookmark-plus")
> +   (synopsis "Extensions to the bookmark.el library in Emacs")

Nitpick: Bookmark (the library) instead of "bookmark.el" (the file).

> +   (description
> +    "Bookmarks are a powerful Emacs feature. This package makes them even more
> +versatile. You can bookmark many more kinds of data. You can add tags. There
> +are many more ways to organize and display your bookmarks. I recommend reading
> +the extensive documentation about BookmarkPlus on the Emacs Wiki.")

Guix usually puts two spaces between sentences.

> +   (license license:gpl3)))

License is actually GPL3+.

Otherwise, LGTM.

Regards,
Nicolas Goaziou April 21, 2023, 2:09 p.m. UTC | #2
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> Otherwise, LGTM.

And thanks for the patch, of course!
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6618aac332..6522012cdd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -349,6 +349,29 @@  (define-public emacs-ace-jump-helm-line
        "This package allows using Ace jump to a candidate in Helm window.")
       (license license:gpl3+))))
 
+(define-public emacs-bookmark-plus
+  (package
+   (name "emacs-bookmark-plus")
+   (version "2022.11.05")
+   (source
+    (origin
+      (method git-fetch)
+      (uri (git-reference
+	    (url "https://github.com/emacsmirror/bookmark-plus")
+	    (commit "3db369056a722c42b3eafd10a91831f87d056dfa")))
+      (sha256
+       (base32
+	"0fnq24f597zfr8jj5h3vr87kdil5lhy11m81q6ayqc03qm0jymrf"))))
+   (build-system emacs-build-system)
+   (home-page "https://github.com/emacsmirror/bookmark-plus")
+   (synopsis "Extensions to the bookmark.el library in Emacs")
+   (description
+    "Bookmarks are a powerful Emacs feature. This package makes them even more
+versatile. You can bookmark many more kinds of data. You can add tags. There
+are many more ways to organize and display your bookmarks. I recommend reading
+the extensive documentation about BookmarkPlus on the Emacs Wiki.")
+   (license license:gpl3)))
+
 (define-public emacs-cfrs
   (package
     (name "emacs-cfrs")