diff mbox series

[bug#72094] gnu: c2ffi: Update to 18.1.0.0.

Message ID e60dac3b7fd35c8dba10aa2967b9e324f782cf36.1720886470.git.attila@lendvai.name
State New
Headers show
Series [bug#72094] gnu: c2ffi: Update to 18.1.0.0. | expand

Commit Message

Attila Lendvai July 13, 2024, 4:01 p.m. UTC
From: Attila Lendvai <attila@lendvai.name>

Change-Id: Ie4a2c35d001a1c74be117312deb5f81d66109dfd
---
 gnu/packages/cpp.scm | 14 ++++++--------
 1 file changed, 6 insertions(+), 8 deletions(-)


base-commit: 71694363f6cc79e44955acbd9f7ca108e658caca

Comments

Z572 July 15, 2024, 1:40 p.m. UTC | #1
attila.lendvai@gmail.com writes:

> From: Attila Lendvai <attila@lendvai.name>
>
> Change-Id: Ie4a2c35d001a1c74be117312deb5f81d66109dfd
> ---
>  gnu/packages/cpp.scm | 14 ++++++--------
>  1 file changed, 6 insertions(+), 8 deletions(-)
>
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index 40181358ba5..ee945fcc683 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -314,23 +314,21 @@ (define-public c2ffi
>      (name "c2ffi")
>      ;; As per the c2ffi README: the first three elements are encoding the
>      ;; required Clang/LLVM version, and the last one is the c2ffi revision.
> -    (version "16.0.0.0")
> +    (version "18.1.0.0")
>      (source
>       (origin
>         (method git-fetch)
>         (uri (git-reference
>               (url "https://github.com/rpav/c2ffi")
> -             ;; Upstream is not tagging releases consistently.
> -             ;; (commit (string-append "v" version))
> -             (commit "097cbe61ca02dc79ea60859aa056975131a9d985")))
> +             (commit (string-append "v" version))))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32 "1mqhw4838chl495gaj9z0731ahkmqb4f3wlc1qalk82fdsaniyd5"))
> +        (base32 "03hw650wjrc4jb4ra8bwc4rnprr0fpnf3wlxzacfjysvl25jb0j6"))
>         (modules '((guix build utils)))
>         (snippet
>          '(substitute* "CMakeLists.txt"
>             ;; Guix seems to be packaging LLVM libs separately thus -lLLVM
> -           ;; won't work, every used library must be specified explicitly.
> +           ;; won't work.  Instead every library used must be listed.
>             (("c2ffi PUBLIC clang-cpp LLVM")
>              "c2ffi PUBLIC clang-cpp LLVMCore LLVMSupport LLVMMCParser \
>  LLVMOption LLVMBitReader LLVMProfileData")))))
> @@ -346,9 +344,9 @@ (define-public c2ffi
>               (when tests?
>                 (invoke "./bin/c2ffi" "--help")))))))
>      (native-inputs
> -     (list clang-16)) ; CMakeLists.txt invokes `clang -print-resource-dir`
> +     (list clang-18)) ; CMakeLists.txt invokes `clang -print-resource-dir`
>      (inputs
> -     (list clang-16)) ; Compiled with gcc, but links against libclang-cpp.so
> +     (list clang-18)) ; Compiled with gcc, but links against libclang-cpp.so
>      (home-page "https://github.com/rpav/c2ffi")
>      (synopsis "Clang-based FFI wrapper generator")
>      (description
>
> base-commit: 71694363f6cc79e44955acbd9f7ca108e658caca

push, see https://git.savannah.gnu.org/cgit/guix.git/commit/?id=1cd1caceedb55ed9f7071ca3f0a15930f563f9c2
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 40181358ba5..ee945fcc683 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -314,23 +314,21 @@  (define-public c2ffi
     (name "c2ffi")
     ;; As per the c2ffi README: the first three elements are encoding the
     ;; required Clang/LLVM version, and the last one is the c2ffi revision.
-    (version "16.0.0.0")
+    (version "18.1.0.0")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/rpav/c2ffi")
-             ;; Upstream is not tagging releases consistently.
-             ;; (commit (string-append "v" version))
-             (commit "097cbe61ca02dc79ea60859aa056975131a9d985")))
+             (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1mqhw4838chl495gaj9z0731ahkmqb4f3wlc1qalk82fdsaniyd5"))
+        (base32 "03hw650wjrc4jb4ra8bwc4rnprr0fpnf3wlxzacfjysvl25jb0j6"))
        (modules '((guix build utils)))
        (snippet
         '(substitute* "CMakeLists.txt"
            ;; Guix seems to be packaging LLVM libs separately thus -lLLVM
-           ;; won't work, every used library must be specified explicitly.
+           ;; won't work.  Instead every library used must be listed.
            (("c2ffi PUBLIC clang-cpp LLVM")
             "c2ffi PUBLIC clang-cpp LLVMCore LLVMSupport LLVMMCParser \
 LLVMOption LLVMBitReader LLVMProfileData")))))
@@ -346,9 +344,9 @@  (define-public c2ffi
              (when tests?
                (invoke "./bin/c2ffi" "--help")))))))
     (native-inputs
-     (list clang-16)) ; CMakeLists.txt invokes `clang -print-resource-dir`
+     (list clang-18)) ; CMakeLists.txt invokes `clang -print-resource-dir`
     (inputs
-     (list clang-16)) ; Compiled with gcc, but links against libclang-cpp.so
+     (list clang-18)) ; Compiled with gcc, but links against libclang-cpp.so
     (home-page "https://github.com/rpav/c2ffi")
     (synopsis "Clang-based FFI wrapper generator")
     (description