diff mbox series

[bug#47697] add guile-fslib

Message ID e6085331-adc5-e7b4-f6f5-93db107e9f49@posteo.de
State Accepted
Headers show
Series [bug#47697] add guile-fslib | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Zelphir Kaltstahl April 10, 2021, 8:35 p.m. UTC
Hello GNU Guix Team,

this patch should add guile-fslib to GNU Guix.

Best regards,
Zelphir

Comments

Ricardo Wurmus May 10, 2021, 10:11 a.m. UTC | #1
Hi Zelphir,

sorry for the delay.  I changed the commit message and made a few 
minor whitespace changes, and the pushed commit 767c3df815.

Thanks!
diff mbox series

Patch

From c3ac8b0ebda8f34a4d1f8cc9411f586c9dcdc3b8 Mon Sep 17 00:00:00 2001
From: Zelphir Kaltstahl <zelphirkaltstahl@posteo.de>
Date: Sat, 10 Apr 2021 22:13:13 +0200
Subject: [PATCH] add guile-fslib

Q: What changes affected a particular source file?
A: Adding guile-fslib adds a public definition to guile-xyz.scm.

Q: Was a particular source file renamed or moved, and if so, as part of what change?
A: No such change.

Q: What changes affected a given function or macro or definition of a data structure?
A: No such change.

Q: Was a function (or a macro or the definition of a data structure) renamed or moved from another file, and if so, as part of which change?
A: No such change.

Q: What changes deleted a function (or macro or data structure)?
A: No such change.

Q: What was the rationale for a given change, and what were its main ideas?
A: The addition of guile-fslib aims to provide helper functions for working with locations in the file system from GNU Guile.

Q: Is there any additional information regarding the change, and if so, where can it be found?
A: The repository of the added library is: https://notabug.org/ZelphirKaltstahl/guile-fslib
---
 gnu/packages/guile-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index b2cbf3e898..043b4f8dba 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -36,6 +36,7 @@ 
 ;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
+;;; Copyright © 2021 Zelphir Kaltstahl <zelphirkaltstahl@posteo.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4671,3 +4672,27 @@  properties inspired by ghc-quickcheck.  You can use it to express properties,
 which functions should satisfy, as Scheme code and then check whether they hold
 in a large number of randomly generated test cases.")
     (license license:gpl3+)))
+
+(define-public guile-fslib
+  (package
+    (name "guile-fslib")
+    (version "0.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://notabug.org/ZelphirKaltstahl/guile-fslib/")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "118d84p443w7hrslv8hjyhgws631ia08mggiyklkmk0b9plfdsvz"))))
+    (build-system guile-build-system)
+    (inputs
+     `(("guile" ,guile-3.0)))
+    (home-page "https://notabug.org/ZelphirKaltstahl/guile-fslib")
+    (synopsis "helper functions for working with location in file systems")
+    (description
+     "This package contains helper functions for working with file system locations.")
+    (license license:agpl3+)))
+
-- 
2.20.1