diff mbox series

[bug#73299,v2,3/3] gnu: go-github-com-golang-protobuf: Remove redundant phase.

Message ID e5fe2c958f1bdadddd3458949c3a973bf064a9ae.1726516329.git.sharlatanus@gmail.com
State New
Headers show
Series [bug#73299,v2,1/3] build/go: Replace symlinks with a copy of the file. | expand

Commit Message

Sharlatan Hellseher Sept. 16, 2024, 8:10 p.m. UTC
* gnu/packages/packages/golang-build.scm (go-github-com-golang-protobuf)
[arguments]: <#:phases>: Remove 'fix-embed-files and relay on standard
one.

Change-Id: Ife4d86e8072588d562364534a66d41ff01851361
---
 gnu/packages/golang-build.scm | 18 ------------------
 1 file changed, 18 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 8fdd652b63..7049acf8c2 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -103,24 +103,6 @@  (define-public go-github-com-golang-protobuf
       #:import-path "github.com/golang/protobuf"
       #:phases
       #~(modify-phases %standard-phases
-          ;; TODO: Implement it in go-build-system.
-          ;;
-          ;; This happens due to Golang can't determine the valid directory of
-          ;; the module of embed file which is symlinked during setup
-          ;; environment phase, but easy resolved after coping file from the
-          ;; store to the build directory of the current package, see details
-          ;; in Golang source:
-          ;;
-          ;; - URL: <https://github.com/golang/go/blob/>
-          ;; - commit: 82c14346d89ec0eeca114f9ca0e88516b2cda454
-          ;; - file: src/cmd/go/internal/load/pkg.go#L2059
-          (add-after 'unpack 'fix-embed-files
-            (lambda _
-              (for-each (lambda (file)
-                          (let ((file-store-path (readlink file)))
-                            (delete-file file)
-                            (copy-recursively file-store-path file)))
-                        (find-files "src" ".*(editions_defaults.binpb)$"))))
           ;; XXX: Workaround for go-build-system's lack of Go modules
           ;; support.
           (delete 'build)