[bug#77738] gnu: Add adwaita-qt5.
Commit Message
* gnu/packages/qt.scm (adwaita-qt5): New variable.
Change-Id: I4554f9f77d14f63e2e3c14fec9ef882677df97f5
---
gnu/packages/qt.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
base-commit: 2934de1447f87b361608ef3a2a756b8a5d2f42e6
@@ -142,6 +142,38 @@ (define-module (gnu packages qt)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public adwaita-qt5
+ (package
+ (name "adwaita-qt5")
+ (home-page "https://github.com/FedoraQt/adwaita-qt")
+ (version "1.4.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FedoraQt/adwaita-qt")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hy2jh5kzrl0319x6a7l043zsvwy85lgljw31f7cvy42klpr5zrb"))))
+ (build-system qt-build-system)
+ (arguments
+ '(#:tests? #f ;no check target
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* '("src/style/CMakeLists.txt")
+ (("DESTINATION \"\\$\\{QT_PLUGINS_DIR\\}")
+ "DESTINATION \"lib/qt5/plugins"))
+ #t)))))
+ (inputs (list qtbase-5
+ qtx11extras))
+ (synopsis "Qt5 Adwaita theme")
+ (description "A style to bend Qt5 applications to look like they belong into
+GNOME Shell")
+ (license license:gpl2+)))
+
(define-public qcoro-qt5
(package
(name "qcoro-qt5")