diff mbox series

[bug#70269,v2] gnu: Add python-pybadges.

Message ID e564b34381c995d0f30ed68f4c92f26f6d089368.1715619952.git.goodoldpaul@autistici.org
State New
Headers show
Series [bug#70269,v2] gnu: Add python-pybadges. | expand

Commit Message

paul May 13, 2024, 5:05 p.m. UTC
* gnu/packages/python-web.scm (python-pybadges): New variable.

Change-Id: Idd53ddf94b24112015c0a0b82396cf366920417e
---
 gnu/packages/python-web.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)


base-commit: aa9ac252206615713ab988d7068da9e14a9bccc0
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index affa2f52f4..df19b30386 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -9183,6 +9183,40 @@  (define-public python-whatthepatch
      "This package provides a library to parse and apply patches.")
     (license license:expat)))
 
+(define-public python-pybadges
+  (package
+    (name "python-pybadges")
+    (version "3.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/google/pybadges")
+                    (commit (string-append version))))
+              (file-name (git-file-name name version))
+              (sha256
+               "1zgb9idz7m3mzf8wvik0gwmyrxp753axqjv2pab326cr5myj1s4b")))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags
+      #~'("-k"
+          ;; Disable network dependent tests.
+          "not test_changes and not test_not_image_url and not test_http_url")))
+    (propagated-inputs (list python-jinja2 python-requests))
+    (native-inputs (list python-flask
+                         python-fonttools
+                         python-nox
+                         python-pillow
+                         python-pytest
+                         python-xmldiff))
+    (home-page "https://github.com/google/pybadges")
+    (synopsis
+     "Generate Github-style badges on the command-line")
+    (description
+     "This package provides @code{python-pybadges}: a library and command-line
+tool for generating Github-style badges as SVG images.")
+    (license license:asl2.0)))
+
 (define-public python-grid5000
   (package
     (name "python-grid5000")