diff mbox series

[bug#74344,5/7] gnu: Add qtpromise.

Message ID e555af2c6b504b7eca8ef64bd2bcbbd617969cbb.1731512783.git.sughosha@disroot.org
State New
Headers show
Series gnu: Add jamesdsp. | expand

Commit Message

Sughosha Nov. 13, 2024, 3:46 p.m. UTC
* gnu/packages/qt.scm (qtpromise): New variable.

Change-Id: I373a383187ec8ba73c2e8fcd5a5a5631d1f80a0d
---
 gnu/packages/qt.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 6108763812..efff50a60c 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4761,6 +4761,43 @@  (define-public qtcsv
      "qtcsv is a library for reading and writing csv-files in Qt.")
     (license license:expat)))
 
+(define-public qtpromise
+  (package
+    (name "qtpromise")
+    (version "0.7.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/simonbrunel/qtpromise")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0nsh6v5k4kdrrhcd6adz947n0dka4rrbx8f8rvm1175545nbi67s"))))
+    (build-system qt-build-system)
+    (arguments
+     (list #:test-target "tests"
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'install 'fix-include-path
+                 (lambda _
+                   (chdir "../source")
+                   (substitute* "include/QtPromise"
+                     (("../src/") ""))))
+               (replace 'install
+                 (lambda _
+                   (let ((include (string-append #$output "/include")))
+                     (install-file "include/QtPromise"
+                                   (string-append include))
+                     (copy-recursively "src/qtpromise"
+                                       (string-append include
+                                                      "/qtpromise"))))))))
+    (home-page "https://qtpromise.netlify.app/")
+    (synopsis "Promises/A+ implementation for Qt/C++")
+    (description
+     "This package provides Promises/A+ implementation for Qt/C++.")
+    (license license:expat)))
+
 (define-public qtcolorwidgets
   (package
     (name "qtcolorwidgets")