[bug#77590,2/3] gnu: Add hdf5-examples.

Message ID e53b09bf33ad34afba3ce25f9b7f9b0a25db26aa.1743980993.git.david.elsing@posteo.net
State New
Headers
Series Update hdf5 to 1.14.6, fix wrappers and remove generated source files. |

Commit Message

David Elsing April 6, 2025, 11:26 p.m. UTC
  * gnu/packages/maths.scm (hdf5-examples): New variable.
---
 gnu/packages/maths.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
  

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e8258b681d..15e4ae6c86 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2017,6 +2017,20 @@  (define-public hdf5
     (license (license:x11-style
               "https://support.hdfgroup.org/ftp/HDF5/releases/COPYING.html"))))
 
+;; This package builds and tests the examples, but has empty output.
+(define-public hdf5-examples
+  (package/inherit hdf5
+    (name "hdf5-examples")
+    (arguments
+     (substitute-keyword-arguments (package-arguments hdf5)
+       ((#:phases _ #f)
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'chdir
+              (lambda _
+                (chdir "HDF5Examples")))))))
+    (inputs (list hdf5 zlib))
+    (native-inputs (list autoconf-2.71 automake gfortran))))
+
 ;; Keep this in sync with the current hdf5 package.
 (define-public hdf-java
   (package