diff mbox series

[bug#61682,v4,1/1] gnu: buildah: Add 'buildah' package

Message ID e526a59655eadcf95343fd7030c3157b867f7261.1679739400.git.zongyuan.li@c0x0o.me
State New
Headers show
Series gnu: buildah: Add 'buildah' package | expand

Commit Message

Zongyuan Li March 25, 2023, 10:25 a.m. UTC
gnu: buildah: Add 'buildah' package

Introduce new 'buildah' package

* gnu/packages/containers.scm: New 'buildah' package
---
 gnu/packages/containers.scm | 66 +++++++++++++++++++++++++++++++++++++
 1 file changed, 66 insertions(+)

--
2.37.1 (Apple Git-137.1)
diff mbox series

Patch

diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index b316588ea2..43d215ea6a 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -406,3 +406,69 @@  (define-public podman
 volumes mounted into those containers, and pods made from groups of
 containers.")
     (license license:asl2.0)))
+
+(define-public buildah
+  (package
+    (name "buildah")
+    (version "1.29.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/containers/buildah")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1mcqkz68fjccdla1bgxw57w268a586brm6x28fcm6x425ah0w07h"))))
+    (build-system go-build-system)
+    (arguments
+      (list #:import-path "github.com/containers/buildah/cmd/buildah"
+            #:unpack-path "github.com/containers/buildah"
+            ; Some dependencies require go-1.18 to build
+            #:go go-1.18
+            #:tests? #f
+            #:install-source? #f
+            #:phases
+            #~(modify-phases %standard-phases
+                (add-after 'unpack 'prepare-install-docs
+                  (lambda* (#:key unpack-path #:allow-other-keys)
+                    (substitute* (string-append "src/"
+                                                unpack-path
+                                                "/docs/Makefile")
+                      (("../tests/tools/build/go-md2man")
+                       (which "go-md2man")))
+                    (substitute* (string-append "src/"
+                                                unpack-path
+                                                "/docs/Makefile")
+                      (("/usr/local") (string-append #$output)))))
+                (add-after 'build 'build-docs
+                  (lambda* (#:key unpack-path #:allow-other-keys)
+                    (let*
+                      ((doc-path (string-append "src/" unpack-path "/docs")))
+                      (invoke "make" "-C" doc-path))))
+                (add-after 'install 'install-docs
+                  (lambda* (#:key unpack-path #:allow-other-keys)
+                    (let*
+                      ((doc-path (string-append "src/" unpack-path "/docs")))
+                      (invoke "make" "-C" doc-path "install")))))))
+    (inputs (list btrfs-progs
+                  cni-plugins
+                  conmon
+                  eudev
+                  glib
+                  gpgme
+                  libassuan
+                  libseccomp
+                  lvm2
+                  runc))
+    (native-inputs
+     (list go-github-com-go-md2man
+           gnu-make
+           pkg-config))
+    (synopsis
+     "Build Open Container Initiative images")
+    (description
+     "Buildah is used to build Open Container Initiative
+@acronym{OCI, Open Container Initiative} compatible containers.")
+    (home-page "https://buildah.io")
+    (license license:asl2.0)))