diff mbox series

[bug#73323,03/15] gnu: aws-c-common: Update to 0.9.27.

Message ID e4ff6ed9dc6275524dc4aedce31959297d2cffac.1726590451.git.code@greghogan.com
State New
Headers show
Series Update aws-sdk-cpp. | expand

Commit Message

Greg Hogan Sept. 17, 2024, 8:16 p.m. UTC
* gnu/packages/c.scm (aws-c-common): Update to 0.9.27.
[arguments]: Disable parallel tests.
[supported-systems]: Add armhf-linux and aarch64-linux.

Change-Id: I66ddf9ed03f8ead70aa1c86792dd4aa8782ac59e
---
 gnu/packages/c.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 62234d3c9a..43c837d251 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -977,7 +977,7 @@  (define-public aws-c-common
   (package
     (name "aws-c-common")
     ;; Update only when updating aws-crt-cpp.
-    (version "0.6.20")
+    (version "0.9.27")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -986,13 +986,15 @@  (define-public aws-c-common
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "089grcj58n4xs41kmnpaqpwsalcisjbqqb5yqahxxyfx2lf1j9c9"))))
+                "1wzlxvcwr4s31c4q8nyj66x3za9s01xzq47ap2jwvr61c93pxcam"))))
     (build-system cmake-build-system)
     (arguments
-     '(#:configure-flags
+     '(#:parallel-tests? #f
+       #:configure-flags
        '("-DBUILD_SHARED_LIBS=ON")))
+    (supported-systems '("armhf-linux" "aarch64-linux"
+                         "i686-linux" "x86_64-linux"))
     (synopsis "Amazon Web Services core C library")
-    (supported-systems '("i686-linux" "x86_64-linux"))
     (description
      "This library provides common C99 primitives, configuration, data
  structures, and error handling for the @acronym{AWS,Amazon Web Services} SDK.")