diff mbox series

[bug#40438] gnu: Add jsonrpc-glib.

Message ID e4f85156b306ed70bfa07b8f3764f841e6f8aad3.camel@zrythm.org
State Accepted
Headers show
Series [bug#40438] gnu: Add jsonrpc-glib. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou April 4, 2020, 8:47 p.m. UTC
Hi,

I was trying to build GNOME builder but it was failing. Anyway, here is
one of its dependencies, would be useful when someone tries to package
it again.

Thanks,
Alex
diff mbox series

Patch

From 85f9832d560fbb4ea032c291bf98f73e3ac74b1f Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 4 Apr 2020 21:45:50 +0100
Subject: [PATCH] gnu: Add jsonrpc-glib.

* gnu/packages/gnome.scm (jsonrpc-glib): New variable.
---
 gnu/packages/gnome.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f93dd2649c..edd7caa4ad 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -50,6 +50,7 @@ 
 ;;; Copyright © 2020 raingloom <raingloom@riseup.net>
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
+;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3402,6 +3403,36 @@  various wrappers for the complex data types employed by JSON, such as arrays
 and objects.")
     (license license:lgpl2.1+)))
 
+(define-public jsonrpc-glib
+  (package
+    (name "jsonrpc-glib")
+    (version "3.32.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://gitlab.gnome.org/GNOME/jsonrpc-glib.git")
+                     (commit version)))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+                (base32
+                  "0mjr4g6jm3nwsjw0mnwnxr7ndnzaq2b2pr92xk1dmnca5znmal34"))))
+    (build-system meson-build-system)
+    (inputs
+     `(("glib" ,glib)
+       ("json-glib" ,json-glib)
+       ("gobject-introspection" ,gobject-introspection)
+       ("vala" ,vala)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://gitlab.gnome.org/GNOME/jsonrpc-glib")
+    (synopsis "JSON-RPC library for GLib")
+    (description "Jsonrpc-GLib is a library to communicate with JSON-RPC
+based peers in either a synchronous or asynchronous fashion.  It also
+allows communicating using the GVariant serialization format instead of
+JSON when both peers support it.  You might want that when communicating
+on a single host to avoid parser overhead and memory-allocator fragmentation.")
+    (license license:lgpl2.1+)))
+
 (define-public libxklavier
   (package
     (name "libxklavier")
-- 
2.26.0