diff mbox series

[bug#74355,1/7] gnu: Add go-github-com-caddyserver-zerossl.

Message ID e4efc9272d37e370d37909a7476b63926c9c5a3f.1731615008.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: Add go-github-com-caddyserver-certmagic. | expand

Commit Message

Artyom V. Poptsov Nov. 14, 2024, 8:12 p.m. UTC
* gnu/packages/golang-web.scm (go-github-com-caddyserver-zerossl): New variable.

Change-Id: Ibec80ae2d4d86f99f8bc271a1c4dfd2591d66290
---
 gnu/packages/golang-web.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 6e47aef039..187718b589 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -641,6 +641,32 @@  (define-public go-github-com-bep-golibsass
      "This package provides SCSS compiler support for Go applications.")
     (license license:expat)))
 
+(define-public go-github-com-caddyserver-zerossl
+  (package
+    (name "go-github-com-caddyserver-zerossl")
+    (version "0.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/caddyserver/zerossl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0hr2kdabhm35hz5krp7m3g6wxvyb9xlqgmy3krf4wwb3yabsqp1m"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/caddyserver/zerossl"))
+    (home-page "https://github.com/caddyserver/zerossl")
+    (synopsis "ZeroSSL REST API client implementation for Go")
+    (description "@code{zerossl} implements the
+@url{https://zerossl.com/documentation/api/, ZeroSSL REST API} in Go.
+
+The REST API is distinct from the @url{https://zerossl.com/documentation/acme/, ACME
+endpoint}, which is a standardized way of obtaining certificates.")
+    (license license:expat)))
+
 (define-public go-github-com-ccding-go-stun
   (package
     (name "go-github-com-ccding-go-stun")