diff mbox series

[bug#37708] gnu: add uchardet

Message ID e4edc1c5-0e0b-405c-8efc-0d0e8b7667bb@pantherx.org
State Accepted
Headers show
Series [bug#37708] gnu: add uchardet | expand

Commit Message

Reza Alizadeh Majd Oct. 11, 2019, 8:21 p.m. UTC
From 5bbab834e617c0bfb14d384e05af390d05728b6e Mon Sep 17 00:00:00 2001
From: Reza Alizadeh Majd <r.majd@pantherx.org>
Date: Fri, 11 Oct 2019 23:23:21 +0330
Subject: [PATCH] gnu: add uchardet

* gnu/packages/freedesktop.scm (uchardet) New variable.
---
 gnu/packages/freedesktop.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

+    (license license:gpl2+)))

Comments

Jonathan Brielmaier Oct. 12, 2019, 8:17 a.m. UTC | #1
On 11.10.19 22:21, Reza Alizadeh Majd wrote:> +    (description
"uchardet is an encoding detector library, which takes
> a +sequence of bytes in an unknown character encoding without any
> additional +information, and attempts to determine the encoding of the
> text. Returned +encoding names are iconv-compatible.")

What does this "+" do here? Are they broken texinfo syntax?
Reza Alizadeh Majd Oct. 12, 2019, 8:49 a.m. UTC | #2
it seems that my mail client brokes the patch content provided in first 
message. please consider to check the attached patch file in my second 
email.


On Saturday, October 12, 2019 11:47:15 AM +0330, Jonathan Brielmaier wrote:
> On 11.10.19 22:21, Reza Alizadeh Majd wrote:> +    (description
> "uchardet is an encoding detector library, which takes
>> a +sequence of bytes in an unknown character encoding without any
>> additional +information, and attempts to determine the encoding of the
>> text. Returned +encoding names are iconv-compatible.")
>
> What does this "+" do here? Are they broken texinfo syntax?
>
>
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 401f54bb14..51848be170 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
+;;; Copyright © 2019 Reza Alizadeh Majd <r.majd@pantherx.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1409,3 +1410,24 @@  This package also contains two related utilities:
 their MIME type.
 @end itemize")
     (license license:perl-license)))
+
+(define-public uchardet
+  (package
+    (name "uchardet")
+    (version "0.0.6")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://www.freedesktop.org/software/" 
+                            name "/releases/" name "-" version ".tar.xz"))
+        (sha256
+          (base32 
"0q9c02b6nmw41yfsiqsnphgc3f0yg3fj31wkccp47cmwvy634lc3"))))
+    (build-system cmake-build-system)
+    (arguments `(#:tests? #f))
+    (home-page "https://www.freedesktop.org/wiki/Software/uchardet/")
+    (synopsis "encoding detector library")
+    (description "uchardet is an encoding detector library, which takes a 
+sequence of bytes in an unknown character encoding without any additional 
+information, and attempts to determine the encoding of the text. Returned 
+encoding names are iconv-compatible.")