diff mbox series

[bug#69272,4/4] gnu: Add prosody-vcard-muc.

Message ID e4e517dd14b3ecd28c0f31f8b492192de8106705.1708345640.git.carlo@zancanaro.id.au
State New
Headers show
Series Refactor prosody modules, and add prosody-vcard-muc. | expand

Commit Message

Carlo Zancanaro Feb. 19, 2024, 12:34 p.m. UTC
* gnu/packages/messaging.scm (prosody-vcard-muc): New variable.

Change-Id: I57eae8373369e7e954084803fd7b861ab85ce4ad
---
 gnu/packages/messaging.scm | 7 +++++++
 1 file changed, 7 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index f360e69fcb..03b7368ae0 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1625,6 +1625,13 @@  (define-public prosody-smacks
 the client and server, it can allow clients to resume a disconnected session,
 and prevent message loss.")))
 
+(define-public prosody-vcard-muc
+  (package
+    (inherit (prosody-module "mod_vcard_muc"))
+    (synopsis "Support for MUC vCards and avatars")
+    (description "This module adds the ability to set vCard for MUC rooms. One
+of the most common use cases is to define avatars for MUC rooms.")))
+
 (define-public libtoxcore
   (let ((revision "2")
         (commit "bf69b54f64003d160d759068f4816b2d9b2e1e21"))