diff mbox series

[bug#68323] gnu: gnupg: Fix cross-compilation.

Message ID e4c359500a04bef3333bc413aaf73ef9497cb34c.1704725707.git.othacehe@gnu.org
State New
Headers show
Series [bug#68323] gnu: gnupg: Fix cross-compilation. | expand

Commit Message

Mathieu Othacehe Jan. 8, 2024, 2:56 p.m. UTC
* gnu/packages/gnupg.scm (gnupg)[arguments]: Pass libraries prefixes when
cross-crompiling.

Change-Id: I461ba02ddf5bb23277bd6685c2106e4ad37e2184
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
---
 gnu/packages/gnupg.scm | 32 +++++++++++++++++++++++++++-----
 1 file changed, 27 insertions(+), 5 deletions(-)


base-commit: 9018c6af4907c4532a95017df9f45d9439c30064
diff mbox series

Patch

diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index a6ba57d7f3..a67eb5c691 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -345,11 +345,33 @@  (define-public gnupg
            zlib))
     (arguments
      (list
-      #:configure-flags #~'(;; Otherwise, the test suite looks for the `gpg`
-                            ;; executable in its installation directory in
-                            ;; /gnu/store before it has been installed.
-                            "--enable-gnupg-builddir-envvar"
-                            "--enable-all-tests")
+      #:configure-flags
+      ;; Always use quasiquote on the next core-updates cycle.
+      #~(#$(if (%current-target-system)
+               #~quasiquote
+               #~quote)
+         (#$@(if (%current-target-system)
+                 #~(,(string-append
+                      "--with-libgpg-error-prefix="
+                      #$(this-package-input "libgpg-error"))
+                    ,(string-append
+                      "--with-libgcrypt-prefix="
+                      #$(this-package-input "libgcrypt"))
+                    ,(string-append
+                      "--with-libassuan-prefix="
+                      #$(this-package-input "libassuan"))
+                    ,(string-append
+                      "--with-ksba-prefix="
+                      #$(this-package-input "libksba"))
+                    ,(string-append
+                      "--with-npth-prefix="
+                      #$(this-package-input "npth")))
+                 #~())
+          ;; Otherwise, the test suite looks for the `gpg`
+          ;; executable in its installation directory in
+          ;; /gnu/store before it has been installed.
+          "--enable-gnupg-builddir-envvar"
+          "--enable-all-tests"))
       #:phases
       #~(modify-phases %standard-phases
           (add-before 'configure 'patch-paths