[bug#77275,v2] gnu: abc: Update to 0.0-5.9f5855f.

Message ID e4178ef06abc39bd12ff615c2d68aad41d009f90.1744279816.git.csantosb@inventati.org
State New
Headers
Series [bug#77275,v2] gnu: abc: Update to 0.0-5.9f5855f. |

Commit Message

Cayetano Santos April 10, 2025, 10:10 a.m. UTC
  * gnu/packages/fpga.scm (abc): Update to 0.0-5.9f5855f.

Change-Id: I7a6570020981fbedf2e6861da0534f199d3839b4
---
 gnu/packages/fpga.scm | 64 +++++++++++++++++++++----------------------
 1 file changed, 32 insertions(+), 32 deletions(-)


base-commit: 07c9a4273152deb128006b5ac2087d5fe30a5927
  

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 893e875276..a1429ecf54 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -80,39 +80,39 @@  (define-module (gnu packages fpga)
   #:use-module (gnu packages version-control))
 
 (define-public abc
- (let ((commit "d5e1a5d445f68bdb4895bb735b9568e5f4738c13")
-       (revision "4"))
-  (package
-    (name "abc")
-    (version (git-version "0.0" revision commit))
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/berkeley-abc/abc")
-                    (commit commit)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0b3qdljcr7dznqr3zxihx9vp6ng6a6pnaqhasblc03rnpp83y1w4"))))
-    (build-system gnu-build-system)
-    (inputs
-     (list readline))
-    (arguments
-     (list #:license-file-regexp "copyright.txt"
-           #:tests? #f ; no tests
-           #:phases
-           #~(modify-phases %standard-phases
-               (delete 'configure)
-               (replace 'install
-                 (lambda _
-                   (install-file "abc" (string-append #$output "/bin")))))))
-    (home-page "https://people.eecs.berkeley.edu/~alanmi/abc/")
-    (synopsis "Sequential logic synthesis and formal verification")
-    (description "ABC is a program for sequential logic synthesis and
+  (let ((commit "d2714035145bd237097c509c23fc9e24b0fa933b")
+        (revision "5"))
+    (package
+      (name "abc")
+      (version (git-version "0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/berkeley-abc/abc")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "10qjw6mbzwg2lgsscw759xrghqq2mvv0xcalpymngnjhpg9qznqk"))))
+      (build-system gnu-build-system)
+      (inputs
+       (list readline))
+      (arguments
+       (list #:license-file-regexp "copyright.txt"
+             #:tests? #f ; no tests
+             #:phases
+             #~(modify-phases %standard-phases
+                 (delete 'configure)
+                 (replace 'install
+                   (lambda _
+                     (install-file "abc" (string-append #$output "/bin")))))))
+      (home-page "https://people.eecs.berkeley.edu/~alanmi/abc/")
+      (synopsis "Sequential logic synthesis and formal verification")
+      (description "ABC is a program for sequential logic synthesis and
 formal verification.")
-    (license
-     (license:non-copyleft
-      "https://people.eecs.berkeley.edu/~alanmi/abc/copyright.htm")))))
+      (license
+       (license:non-copyleft
+        "https://people.eecs.berkeley.edu/~alanmi/abc/copyright.htm")))))
 
 (define-public iverilog
   (package