diff mbox series

[bug#74398,3/4] gnu: sonivox-eas: Update to 1.5.1.

Message ID e4178d7075f088d0aad94adcbb409366428c390b.1731857716.git.sughosha@disroot.org
State New
Headers show
Series gnu: vmpk: Update to 0.9.0. | expand

Commit Message

Sughosha Nov. 17, 2024, 3:35 p.m. UTC
* gnu/packages/music.scm (sonivox-eas): Update to 1.5.1.
[build-system]: Switch to qt-build-system.
[arguments]<#:qtbase>: Use qtbase.
[inputs]: Remove qtbase-5. Add qtwayland and sonivox.
[license]: Remove asl2.0.

Change-Id: If65a359fcc70254f69edda318a72ea957572fb3f
---
 gnu/packages/music.scm | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index cf5dfa8493..ed260d27ba 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5916,7 +5916,7 @@  (define-public sonivox
 (define-public sonivox-eas
   (package
     (name "sonivox-eas")
-    (version "1.3.0")
+    (version "1.5.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -5925,11 +5925,13 @@  (define-public sonivox-eas
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "1ygmlrsdzxii2dvj6id2ai3xv3klw2x67ip5rcp823jzczl0wpjd"))))
-    (build-system cmake-build-system)
-    (arguments '(#:tests? #f)) ; there are no tests
+                "1y67bi2vcwb1avwz18i41q85cmqx9svwx4q3kpmh951l49s9k8vz"))))
+    (build-system qt-build-system)
+    (arguments
+     (list #:qtbase qtbase
+           #:tests? #f)) ; there are no tests
     (inputs
-     (list alsa-lib drumstick pulseaudio qtbase-5))
+     (list alsa-lib drumstick pulseaudio qtwayland sonivox))
     (native-inputs
      (list pkg-config))
     (home-page "https://github.com/pedrolcl/Linux-SonivoxEas")
@@ -5937,9 +5939,7 @@  (define-public sonivox-eas
     (description "This project is a real time General MIDI synthesizer based
 on the Sonivox EAS Synthesizer by Google.  It does not need external
 soundfonts, using embedded samples instead.")
-    ;; Sonivox is released under the ASL2.0; the rest of the code is under
-    ;; GPLv2+.
-    (license (list license:gpl2+ license:asl2.0))))
+    (license license:gpl2+)))
 
 (define-public whysynth
   (package