[bug#77339,mesa-updates,03/15] gnu: Add cmake-minimal-3.30.
Commit Message
* gnu/packages/cmake.scm (cmake-minimal-3.30): New variable.
Change-Id: I8cff557e1510ddd183955795ed4119fef50b5385
---
gnu/packages/cmake.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
--
2.49.0
@@ -439,6 +439,31 @@ (define-public cmake-3.30
(prepend (module-ref (resolve-interface '(gnu packages debug))
'cppdap))))))
+(define-public cmake-minimal-3.30
+ (package
+ (inherit cmake-minimal)
+ (version "3.30.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://cmake.org/files/v"
+ (version-major+minor version)
+ "/cmake-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1r48zym4dy4mvwzk704zh1vx9gb4a910f424ypvis28mcxdy2pbd"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments cmake-minimal)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (delete 'delete-help-documentation)))))
+ (native-inputs
+ (modify-inputs (package-native-inputs cmake-minimal)
+ ;; Avoid circular dependency with (gnu packages debug). Note: cppdap
+ ;; is built with cmake, so when the default cmake-minimal is updated to
+ ;; this version this circular dependency will need to be worked around.
+ (prepend (module-ref (resolve-interface '(gnu packages debug))
+ 'cppdap))))))
+
(define-public cmake-minimal-cross
(package
(inherit cmake-minimal)