diff mbox series

[bug#46962] gnu: Add git2cl.

Message ID e4091a9f399ae284a6d55627c7f6455332a617e3.1615022804.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#46962] gnu: Add git2cl. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen March 6, 2021, 9:28 a.m. UTC
* gnu/packages/version-control.scm (git2cl): New variable.
---
 gnu/packages/version-control.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: 112692c0d546d35cd67c5dc70dbd1dc609b18f64

Comments

Ludovic Courtès March 19, 2021, 8:52 p.m. UTC | #1
Hi,

Xinglu Chen <public@yoctocell.xyz> skribis:

> * gnu/packages/version-control.scm (git2cl): New variable.

I changed the license to ‘gpl2+’ (meaning “or any later version”),
capitalized “Git”, and committed.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 8292a5df15..c363aadfdf 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -36,6 +36,7 @@ 
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Chris Marusich <cmmarusich@gmail.com>
 ;;; Copyright © 2021 Léo Le Bouter <lle-bout@zaclys.net>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -599,6 +600,32 @@  everything from small to very large projects with speed and efficiency.")
        ("perl" ,perl)
        ("zlib" ,zlib)))))
 
+(define-public git2cl
+  (let ((commit "1d74d4c0d933fc69ed5cec838c73502584dead05"))
+    (package
+      (name "git2cl")
+      (version (string-append "20120919." (string-take commit 7)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://git.savannah.nongnu.org/git/git2cl.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0wnnbm2sjvfj0qrksj89jlnl69miwl0vk3wrrvgvpclgys3na2g1"))))
+      (build-system copy-build-system)
+      (inputs
+       `(("perl" ,perl)))
+      (arguments
+       `(#:install-plan
+         '(("git2cl" "bin/git2cl"))))
+      (home-page "https://savannah.nongnu.org/projects/git2cl")
+      (synopsis "Convert git logs to GNU ChangeLog format")
+      (description "@code{git2cl} is a command line tool for converting git
+logs to GNU ChangeLog format.")
+      (license license:gpl2))))
+
 (define-public gitless
   (package
     (name "gitless")