diff mbox series

[bug#54457,6/9] gnu: Add libnetfilter-acct

Message ID e3f547e4-5400-b5be-1e5d-1284990de38e@gmail.com
State Accepted
Headers show
Series None | expand

Commit Message

fesoj000 March 21, 2022, 9:20 p.m. UTC
* gnu/packages/linux.scm (libnetfilter-acct): New variable.
---
  gnu/packages/linux.scm | 31 +++++++++++++++++++++++++++++++
  1 file changed, 31 insertions(+)

Comments

fesoj000 March 21, 2022, 9:31 p.m. UTC | #1
> +     (uri (string-append "https://netfilter.org/projects/" name "/files/" name
> +                         "-" version ".tar.bz2"))
wrong patch ... resending shortly.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7ba43bb60f..bc9e4697f0 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7394,6 +7394,37 @@  (define-public conntrack-tools
     (home-page "https://netfilter.org/projects/conntrack-tools/index.html")
     (license license:gpl2+)))
  
+(define-public libnetfilter-acct
+  (package
+   (name "libnetfilter-acct")
+   (version "1.0.3")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append "https://netfilter.org/projects/" name "/files/" name
+                         "-" version ".tar.bz2"))
+     (sha256
+      (base32
+       "06lsjndgfjsgfjr43px2n2wk3nr7whz6r405mks3887y7vpwwl22"))))
+   (build-system gnu-build-system)
+   (supported-systems (filter target-linux? %supported-systems))
+   (native-inputs (list pkg-config))
+   (inputs (list libmnl))
+   (synopsis "Library providing interface to extended accounting infrastructure.")
+   (description "libnetfilter_acct is the userspace library providing interface
+to extended accounting infrastructure.
+@enumerate
+@item
+creating accounting objects
+@item
+retrieving accounting objects (and atomically set to zero)
+@item
+deleting accounting objects
+@end enumerate
+For the nfnetlink_acct subsystem.")
+   (home-page "https://netfilter.org/projects/libnetfilter_acct/index.html")
+   (license license:lgpl2.1+)))
+
  (define-public proot
    (package
      (name "proot")